Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 1st Gen S-series (1983-1994) Tech
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-25-2011, 12:21 AM
Starting Member
1995 Chevrolet S10 Blazer
My Garage
 
Join Date: May 2009
Location: IN
Posts: 214
bam_9_9_9 is on a distinguished road
SxB BAM FRESH
Default 94 blazer lots of problems...Help

just bought another s10 blazer after i totaled my 93 its a 94 s10 blazer cpi. the engine light, anti lock light, and parking break light is on. got the engine light to go off. i pulled the codes for the engine light and said that the air temp sensor was bad so i got my old one from the 93 and it worked. reset the codes and no engine light now.

so the anti lock light is still on ive got 17 codes from this light. you have to jumper a different wire to get the codes for the abs system. so here are the codes

67 74 46 41 42 51 52 66 72 86 12 25 35 27 37 45 65

i know its alot but i havent reset the codes on the abs side. i unplugged the battery to reset the engine light but my manual tells my i have to jumper the wire for a few seconds then let off then jumper them again to reset those codes. you would think that unplugging the battery would reset them but whatever. i just found out about that tonight will try in the mornin.

my ac compressor i think is squeeling real bad. the guy i bought it off of put some belt dressing in the ac cluch and seemed to help like it would sqeel every sec or every turn of the engine but when you hit the gas it goes away. now after a day it squeels real bad constantly even with the pedal down. its realllllly loud! would i be able to take the clutch out of the ac and still have the pully there?

i took the belt off and free spun all pullys and no sound came out of them. the power steering pump pully was a little loose though but no alot.

another problem only my driver side window will roll down. all the others will not roll down at all not even a little bit. the passenger side windows make a little faint click when you try to roll them down but the driver side rear window will not click.

the parking brake is all the way up. might be the switch under the dash i dont know.

thanks for reading all this if you got this far LOL. any help is much appreciated thanks
__________________
1993 S10 Blazer Vin W RIP 4/4/2011
1994 S10 Blazer Vin W SOLD
1995 S10 Blazer Vin W DD
http://www.youtube.com/user/bam6972
Reply With Quote
  #2  
Old 04-25-2011, 02:24 AM
Starting Member
 
Join Date: Jan 2011
Posts: 207
Cidium is on a distinguished road
Default

I have the code book for ABS, these are the codes for a 93 4WAL system:

(12) I think this just means the system diagnostic is working
(25) Left front wheel speed sensor resistance incorrect
(27) Left front wheel speed sensor output voltage is erratic
(35) Left rear wheel speed sensor resistance incorrect
(37) Left rear wheel speed sensor output voltage is erratic
(45) Left front isolation valve solenoid open
(46) Left front pulse width modulation valve solenoid open circuit
(51) Rear isolation valve solenoid open circuit
(52) Rear pulse width modulation valve solenoid open circuit
(65-66-67) Pump motor relay open circuit, Pump motor relay short circuit, .................Pump motor relay open circuit.
(72-74) EHCU has ROM error, EHCU internal error

I have no idea what all this means or how to fix them.

You could always bypass the AC pump with a bypass pulley. I have seen them on Ebay for around 30 bucks. I have no idea what it takes to gut the clutch on the pump.

If it was me, I would take the door panels and check the window rails and crank mechanism to make sure it was working.
Reply With Quote
  #3  
Old 04-25-2011, 07:25 PM
Outsydr's Avatar
Senior Member
1994 Chevrolet Blazer
 
Join Date: May 2007
Location: Warren, Ohio
Posts: 591
Outsydr is an unknown quantity at this point
Default

is the abs light on all the time or just at certain speeds? (I had an issue with mine where it would only come on at 15mph and above) Check link in my sig for the codes how to clear etc (it's posted in the diy section of this forum sig just links to that)
You can always just buy a belt for a non-ac equipped version of your truck and eliminate that completely. (check your belt first if no noise from the pulleys when spinning by hand the belt may be glazed over and slipping causing the squealing)
power or manual windows going by the click description I am assuming power, very likely the motors are bad it's not uncommon check ebay got all 4 of mine on there for $90 shipped (that's the total for all 4 at once just to be clear on that) if you still have your 93 available and they are good I would yank one and try it before spending any money (the switches are also not uncommon for going bad)
__________________

My Car Domain
1st gen ABS codes how-to
Henry Ford may have built the first car but GMC = God Made Chevy

Reply With Quote
  #4  
Old 04-25-2011, 11:02 PM
Starting Member
1995 Chevrolet S10 Blazer
My Garage
 
Join Date: May 2009
Location: IN
Posts: 214
bam_9_9_9 is on a distinguished road
SxB BAM FRESH
Default

the antilock light is on all the time. i tryed clearing the codes but the antilock light will not stay off and i still have the same codes. for some reason it wont erase. my haynes manual told me to jumper a and h for 2 seconds with key on then let off for 1 second then back on for 2 seconds. but the light does not stay off. ill try it again tomorrow letting off for 2 seconds to see if it clears them.

any idea why my parking break light is on even though my parking break is up or released.
__________________
1993 S10 Blazer Vin W RIP 4/4/2011
1994 S10 Blazer Vin W SOLD
1995 S10 Blazer Vin W DD
http://www.youtube.com/user/bam6972
Reply With Quote
  #5  
Old 04-26-2011, 02:07 AM
Starting Member
 
Join Date: Jan 2011
Posts: 207
Cidium is on a distinguished road
Default

Check this site out, maybe this can help.
Kelsey-Hayes 4WAL Antilock Brakes

I run across this write-up, says something about brake light on.

"Self-Tests

Two different self-tests are performed whenever the vehicle is started. The first happens as soon as the key is turned on. During this period, the red BRAKE and yellow ANTILOCK lights will come on for 2 seconds. The ECU then tests for continuity in the wheel speed sensor circuits and for proper voltage in the pump circuit. The ANTILOCK light should turn off if no electrical faults are detected; the BRAKE lamp will stay on if either the parking brake is applied or there's a hydraulic problem in the brake circuits. "

Last edited by Cidium; 04-26-2011 at 04:52 AM.
Reply With Quote
  #6  
Old 05-02-2011, 09:51 PM
Starting Member
1995 Chevrolet S10 Blazer
My Garage
 
Join Date: May 2009
Location: IN
Posts: 214
bam_9_9_9 is on a distinguished road
SxB BAM FRESH
Default

could it be possible that the computer is bad. like the abs side of the computer is corrupted or something. im still getting 17 codes from the abs light. i tryed reseting it but the book said when it resets the light will go out. and stay out. but i cant get the light to stay off after jumping the terminals for 2sec then off for 1-2 sec then again for 2sec. the light will not stay off. its like it wont reset. and code 12 is one of the 17 and the book says that code 12 is the ecu is messed up so i dont know what to do.

the engine light came on again and code 32 popped up. ugh gotta get a egr valve gasket and clean the egr valve. the light goes out after a bit but come back on randomly.
__________________
1993 S10 Blazer Vin W RIP 4/4/2011
1994 S10 Blazer Vin W SOLD
1995 S10 Blazer Vin W DD
http://www.youtube.com/user/bam6972
Reply With Quote
  #7  
Old 05-03-2011, 03:28 AM
Starting Member
 
Join Date: Jan 2011
Posts: 207
Cidium is on a distinguished road
Default

Hey bam,

You can clear the codes all day but if there is a system fault the ABS light is always going to come back on. I mean think about it, if there was a way to cancel the ABS warning (besides pulling the dash bulb), and still have a system fault that could be dangerous. I know this seems overwhelming, but first decide if you need/want the ABS working. Are you the kind of driver that gives plenty of room between cars are do you ride up on people? If you want the ABS working I suggest you take each error code one at a time and trace it to fix it. Check and clean the connectors to left side, rear and front, wheel sensors. At the same time you can check the resistance of each sensor, just use and ohm meter on each lead of the sensor when the connector in unplugged. This might clear half the codes. Also, the code clearing procedure with the jumper might take more than two attempts of jumping. Here's what I did, find the 2 pins in the harness that clear codes, jump those 2 pins till you hear the ABS pump start to cycle. Pull the wire on one pin to stop the pump and count - 1000 one - plug the wire back in till you hear the pump cycle and repeat this maybe as many as 5-6 times. I know my manual said 2 times but I think that didn't work so I just did it till I thought I had cleared the codes.

Oh yeah, I get a code 12 on my ABS light and my ABS is working.
Reply With Quote
  #8  
Old 05-07-2011, 10:01 PM
Starting Member
1995 Chevrolet S10 Blazer
My Garage
 
Join Date: May 2009
Location: IN
Posts: 214
bam_9_9_9 is on a distinguished road
SxB BAM FRESH
Default

ok i still cant get the really loud constant squeel/screaching sound to go away. if i spray water on the belt it goes away for a few seconds, if i spray alot on it will go away up to 15 seconds. i took the ac compressor out and rented some tools and took the clutch and coil out and left just the pully and put it back on. it still wont go away. the guy that had it before me sprayed a ton of belt dressing on it and didnt do it as bad but now its constant and really loud. gets louder and faster when the throttle is pressed down. i took the belt off and free spun all pullys and none seem to be making a noise or wobbling. the only thing i can think of is that the belt is bad. but looked in good shape, no cracks. the idler pully seems to be new.
__________________
1993 S10 Blazer Vin W RIP 4/4/2011
1994 S10 Blazer Vin W SOLD
1995 S10 Blazer Vin W DD
http://www.youtube.com/user/bam6972
Reply With Quote
  #9  
Old 05-07-2011, 11:54 PM
Starting Member
 
Join Date: Jan 2011
Posts: 207
Cidium is on a distinguished road
Default

here's what the bypass pulley looks like, might even find one cheaper.

S10 S15 Sonoma 4.3L AC Bypass Pulley 1988-1995 | eBay

I was looking at mine today and it looks like with a shorter belt you can bypass the AC without a bypass pulley but the belt would be really close to the water pump pulley. Either way you got to spend money on a shorter belt or the bypass pulley or by the sounds of it, the baring on the AC pulley.

I would make sure it's not coming from the idler pulley under the AC compressor first.

Last edited by Cidium; 05-07-2011 at 11:56 PM.
Reply With Quote
  #10  
Old 10-06-2012, 10:14 PM
Starting Member
1995 Chevrolet S10 Blazer
My Garage
 
Join Date: May 2009
Location: IN
Posts: 214
bam_9_9_9 is on a distinguished road
SxB BAM FRESH
Default

FIXED THE ABS!! took the computer out from under the dash and the abs computer is sepperate from the ecu. the abs computer is mounted on the side of the ecu. so i took the abs computer apart and found a BAD CAPACITOR on the motherboard. so i found a capacitor from a tv board of the same values and soldered it in. put it back together and BAM only one code. its the left front wheel speed sensor. so if you have a abs problem that puts out all of the abs codes then its probally the same capacitor. well theres only one on the whole motherboard. but yea its works now. :icon_bi ggrin:
__________________
1993 S10 Blazer Vin W RIP 4/4/2011
1994 S10 Blazer Vin W SOLD
1995 S10 Blazer Vin W DD
http://www.youtube.com/user/bam6972
Reply With Quote
Old 10-06-2012, 10:14 PM
 
 
 
Reply

Tags
1993, 1994, 41, 94, abs, antilock, blazer, break, chevy, code, codes, computer, cpi, reset, s10, sonoma


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 12:28 PM.

Internet Brands, Inc.