Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 1st Gen S-series (1983-1994) Tech
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Closed Thread
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-28-2007, 09:33 PM
 
Join Date: Oct 2007
Location:
Posts: 28
Brandon31386 is an unknown quantity at this point
Default High Idle at Startup

I have a 92 S10 blazer with the 4.3 non vortec engine. When i start it up, the idle is very high. And it shouldnt be that high. And ideas on what it could be??
__________________
1992 S10 Blazer 4.3 4WD

"If women cant find you handsome, they should at least find you handy"
  #2  
Old 10-28-2007, 09:57 PM
rriddle3's Avatar
Administrator
2013 Cadillac ATS
 
Join Date: Dec 2006
Location: Fort Worth,Texas
Posts: 5,908
rriddle3 has a reputation beyond reputerriddle3 has a reputation beyond reputerriddle3 has a reputation beyond reputerriddle3 has a reputation beyond reputerriddle3 has a reputation beyond reputerriddle3 has a reputation beyond reputerriddle3 has a reputation beyond reputerriddle3 has a reputation beyond reputerriddle3 has a reputation beyond reputerriddle3 has a reputation beyond reputerriddle3 has a reputation beyond repute
Default RE: High Idle at Startup

If it's a 4.3L V6, it's a Vortec. How high is 'very high'? When does the idle speed drop down?
  #3  
Old 10-29-2007, 06:28 AM
 
Join Date: Feb 2006
Location:
Posts: 820
DetroitMuscle is an unknown quantity at this point
Send a message via AIM to DetroitMuscle Send a message via Yahoo to DetroitMuscle
Default RE: High Idle at Startup

Quote:
ORIGINAL: rriddle3

If it's a 4.3L V6, it's a Vortec. How high is 'very high'? When does the idle speed drop down?
Its not only vortecs in 1992, he has the z code TBI 4.3, and yes the idle is high when its cold, like around 2k rpms. Mine does the same thing and I wasted money changing things and it doesnt help.
__________________


http://www.blazerforum.com/albumphoto.asp?albumid=150&asortType=1&apage=1
  #4  
Old 10-29-2007, 11:16 AM
swartlkk's Avatar
Administrator
2009 GMC Yukon Denali
My Garage
 
Join Date: May 2005
Location: Waterloo, NY
Posts: 36,947
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Send a message via ICQ to swartlkk Send a message via AIM to swartlkk
Default RE: High Idle at Startup

I could have sworn I posted here... Anyway, the 'vortec' head design came about in the mid-80's. It wasn't until the early 90's when it became a marketing buzz word.

Anyway, back to the problem at hand. I guess we need a quantification to the term 'idles very high'. At what RPM does it idle at when cold. Does it drop down to a normal idle after it is warmed up? If it does, what is the idle RPM warmed up?
  #5  
Old 10-29-2007, 07:28 PM
 
Join Date: Feb 2006
Location:
Posts: 820
DetroitMuscle is an unknown quantity at this point
Send a message via AIM to DetroitMuscle Send a message via Yahoo to DetroitMuscle
Default RE: High Idle at Startup

Quote:
ORIGINAL: swartlkk

I could have sworn I posted here... Anyway, the 'vortec' head design came about in the mid-80's. It wasn't until the early 90's when it became a marketing buzz word.

Anyway, back to the problem at hand. I guess we need a quantification to the term 'idles very high'. At what RPM does it idle at when cold. Does it drop down to a normal idle after it is warmed up? If it does, what is the idle RPM warmed up?
I think it was 87ish when the "vortec" design came about, but I also believe that you need a different intake to fit that vortec design or atleast that the way it was with a 90 degree SBC V8.
__________________


http://www.blazerforum.com/albumphoto.asp?albumid=150&asortType=1&apage=1
  #6  
Old 10-29-2007, 07:36 PM
swartlkk's Avatar
Administrator
2009 GMC Yukon Denali
My Garage
 
Join Date: May 2005
Location: Waterloo, NY
Posts: 36,947
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Send a message via ICQ to swartlkk Send a message via AIM to swartlkk
Default RE: High Idle at Startup

Again, do not confuse the change in the intake manifold bolt orientation with the start of the vortec cylinder head design. All 4.3L engines utilized vortec cylinder heads. Not that Wikipedia is a be-all and end-all source for accurate information, but they have it right in this case: GM Vortec Engine
  #7  
Old 10-29-2007, 08:42 PM
 
Join Date: Oct 2007
Location:
Posts: 28
Brandon31386 is an unknown quantity at this point
Default RE: High Idle at Startup

Its not a Vortec...and i cannot tell what the RPM is because there is no tach. someone told me its either a sensor or a vacuum leak around the throttle body.
__________________
1992 S10 Blazer 4.3 4WD

"If women cant find you handsome, they should at least find you handy"
  #8  
Old 10-29-2007, 09:05 PM
swartlkk's Avatar
Administrator
2009 GMC Yukon Denali
My Garage
 
Join Date: May 2005
Location: Waterloo, NY
Posts: 36,947
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Send a message via ICQ to swartlkk Send a message via AIM to swartlkk
Default RE: High Idle at Startup

You are not listening, but what do I know...[&o]

Anyway, the TBI motors do have a problem with the throttle body base gasket. You can troubleshoot vacuum leaks by spraying some carb cleaner around the base of the throttle body.

Does the idle ever return to normal?
  #9  
Old 10-29-2007, 10:11 PM
 
Join Date: Oct 2007
Location:
Posts: 28
Brandon31386 is an unknown quantity at this point
Default RE: High Idle at Startup

sometimes it returns to normal on its own, sometimes it wont return to normal until i start driving.

and i always thought the vortec engine was the one with the intake manifold and fuel injected. im not too educated on my truck, ive been slacking
__________________
1992 S10 Blazer 4.3 4WD

"If women cant find you handsome, they should at least find you handy"
  #10  
Old 10-30-2007, 06:26 AM
 
Join Date: Feb 2006
Location:
Posts: 820
DetroitMuscle is an unknown quantity at this point
Send a message via AIM to DetroitMuscle Send a message via Yahoo to DetroitMuscle
Default RE: High Idle at Startup

Quote:
ORIGINAL: Brandon31386

sometimes it returns to normal on its own, sometimes it wont return to normal until i start driving.

and i always thought the vortec engine was the one with the intake manifold and fuel injected. im not too educated on my truck, ive been slacking
Let it warm up, it should drop on its own, atleast thats the way my 92 is.

Kyle, thats something I didnt know I thought the two went hand in hand.
__________________


http://www.blazerforum.com/albumphoto.asp?albumid=150&asortType=1&apage=1
Old 10-30-2007, 06:26 AM
 
 
 
Closed Thread

Tags
2002, 43l, 92, blazer, chevy, fast, hard, high, idle, normal, revs, rpm, s10, shifting, start, vortec


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 05:12 AM.

Internet Brands, Inc.