Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 1st Gen S-series (1983-1994) Tech
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-05-2012, 07:29 PM
New Member
 
Join Date: Jul 2012
Posts: 8
Swimslikearock is on a distinguished road
Default How to remove TBI fuel injectors?

my first post!, I have an 88, 350. engine won't start unless I hit it with Starting fluid. seesm to run ok after start but turn it off and it wont start again after running and driving. we see that the injectors are not dispensing fuel while cranking the starter. I took the TBI off and cleaned it but can't see how to get the injector out of the TBI. is it worth it to buy the rebuild kit? <$30. the reman'd TBI is $379+. i'd like to try the rebuild first. any and all tips welcomed.
thanks.
Reply With Quote
  #2  
Old 07-08-2012, 01:36 AM
neo71665's Avatar
Super Member
 
Join Date: Dec 2007
Location: rison AR
Posts: 1,941
neo71665 will become famous soon enoughneo71665 will become famous soon enough
Send a message via Yahoo to neo71665
Default

WitchHunter Performance - Throttle Body injector removal
__________________
1987 s-10 blazer 4x4, 3.4, 700r4, np207, 3.73 gears...dana 60s, built 5.7 sitting in the shop working on custom frame and linked suspenstion (soon to be a true S-TON blazer)
1991 gmc sonoma reg cab, bone stock....3.4 swap coming
Reply With Quote
  #3  
Old 07-17-2012, 04:52 PM
Beginning Member
 
Join Date: Jun 2011
Posts: 24
jrakers2 is on a distinguished road
Default

I have the same TBI simple to repair or replace. To pull injectors take top plate off top of injectors ( 8 screws ) then take a flat head screwdriver and put something in between it and top for leverage. The injector has a lip around the very top so put the srewdriver under the lip and pop the injector out. The tbi kit is simple and with gaskets to replace for the injectors to. I don't see a kit needed unless your fuel presure valve is leaking on the outside of the tbi. Why I say that is there is nothing to replace but gaskets and a spring.
Reply With Quote
  #4  
Old 07-17-2012, 05:24 PM
chris015's Avatar
BF Veteran
1993 Chevrolet S10 Blazer
 
Join Date: Apr 2009
Location: South Carolina
Posts: 3,588
chris015 has a spectacular aura aboutchris015 has a spectacular aura aboutchris015 has a spectacular aura about
YOUMADBRAHLOL
Default

Yea^^

Man,sounds like the check it valve is leaking in the fuel pump. Turn your key on,count to 3,turn it off,then back on,count to 3 then start the truck. does it start better? if so its the pump.

Whens the last time you changed the filter?

If you do buy a pump. you must buy ac delco pumps for these trucks.
__________________
Like a boss.
Reply With Quote
  #5  
Old 07-18-2012, 11:24 AM
New Member
 
Join Date: Jul 2012
Posts: 8
Swimslikearock is on a distinguished road
Default TBI rebuild

Thanks for the replies. the TBI rebuild was pretty easy, once i figured out the Injectors are just and o-ring fit intot he injector body. but i still have the same issue, there's no fuel going into the intake manifold while trying to start. a shot of starting fluid will make it start and run. i can see the fuell flowing out of the injectors when it is running. there are no leaks at the regulator or the lines. next step change the filter, and blow out the lines. then on to the the pump/ tank.
i read lots of stuff about adding a spacer under the tbi, is this really a perfromance boost? are there consequences?

thanks for all the help and helpful suggestions.
Swims
Reply With Quote
  #6  
Old 07-18-2012, 09:13 PM
New Member
 
Join Date: Jul 2012
Location: Mountain Home, Ar
Posts: 2
blitzmick is on a distinguished road
PRIM3 B3AST
Default

You do get a performance boost, enough you'll notice but no supercharger lol. Have you checked the fuel pump relay? Sometimes they can be tedious
Reply With Quote
  #7  
Old 07-19-2012, 07:48 AM
Beginning Member
 
Join Date: Jun 2011
Posts: 24
jrakers2 is on a distinguished road
Default

This is real funny but I know have the same problem you have. I have been jacking with my fuel - mileage problem for a year know. The day I answered your post I had replaced my new injectors with my old to see if they were a idol problem. I got my mileage problem solved with a new throttle position censor and 200.00 of other parts. I changed out injectors and it wouldn't start. I smelled gas, couldn't see how much was cumming out so I changed back to the new injectors and it still didn't start. I got mad and walked away from that SOB for a week. I'm back on it today, I'm going to try a shot of starter fluid to see if it stars. All and all we got the same problem it looks like. I'm getting fire, it has a new coil, wires all that crap new. Rebuilt the TBI which I said was nothing to it to be bad but leak. My idol was rough at fist till it warmed up. When taking off it would run good then cut back then run good till 40 up then run fine as long as you where past 40. I would stop and go in a store come out and it would idol better and run better, never right though. Every time was a different way it ran. So like I said I have been jacking with this over a year now and getting tired and never have the money. It seems that every thing I change helps a little but never right. I have a 87 2.8 61,000 actual miles. It is old but no miles and it was taken care of before me. I won't know how to act if it ran like it suppose to LOL. Looks like it boils down to injectors no gas. I know the injectors go in a certain way, the electronic studs are suppose to line up strait with each other when set right or it won't run right. Keep in touch I'm going out to get mad with my auto
Reply With Quote
  #8  
Old 07-19-2012, 03:11 PM
New Member
 
Join Date: Jul 2012
Posts: 8
Swimslikearock is on a distinguished road
Default TBI/Fuel system issues

I take no pleasurre hearing you have similar problems. my next step will be to R&R the filter and blow out the fuel lines from the TBI back to the filter.
it does not take much starting fluid, too much and it might flood. learned that the hard way. I'm also looking into fuel pressure gauges. I've read about some adjustable gauges that attach to the back of the TBI. I have 1988, 5.7.i too replaced the coil, cap, wires, and rotor first. Please keep posting your results.

swims
Reply With Quote
  #9  
Old 07-20-2012, 02:45 PM
Beginning Member
 
Join Date: Jun 2011
Posts: 24
jrakers2 is on a distinguished road
Thumbs up

Well I have decided it is my computer. I have changed everything but it, if it's not the computer where can I get dynamite?
Reply With Quote
  #10  
Old 07-25-2012, 06:44 PM
New Member
 
Join Date: Jul 2012
Posts: 8
Swimslikearock is on a distinguished road
Default still has starting problems

i replaced the fuel filter, during which I disconnected the lines from the back of the TBI and blew 50 psi thru both lines and got good flow. when i tried to start it after the filter, i did hear the fuel pump run for several seconds while it refilled the lines. it would not start, a shot of starting fluid and it fires up and runs, drove it around the block, turned it off and it will not start without SF. Throttle position sensor? could it be the injectors? they seem clean after the rebuild the TBI.
Reply With Quote
Old 07-25-2012, 06:44 PM
 
 
 
Reply

Tags
350, 43, 95, change, clean, fluid, fuel, fule, injector, injectors, s10, screens, start, starting, tbi, wont


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
how do i remove poppet replacement injectors from the intake manifold? kevlar974 2nd Gen S-series (1995-2005) Tech 7 03-18-2011 07:55 PM
4.3 tbi,no fuel from injectors chris015 1st Gen S-series (1983-1994) Tech 4 12-31-2010 11:30 AM

Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 04:48 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.