1995 Hesitation issues - Blazer Forum - Chevy Blazer Forums

Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech

LinkBack Thread Tools Search this Thread
Old 09-08-2012, 10:12 PM
New Member
Join Date: May 2006
Posts: 4
awhoff is an unknown quantity at this point
Default 1995 Hesitation issues

I am hoping someone can provide help on the hesitation problem I am
having with my 95 Blazer, It is a 4dr, 2wd V6 4.3. It starts and idles fine, however
when I put it in D and press the gas it hiccups and hesitates. Me and my friends
have already check fuel filter, and replaced the Idle Air Control Valve. In the last
year i have already replaced the ECM, EGR, Spark plugs and wires, and distributor.
The Hoff
Reply With Quote
Old 09-08-2012, 11:07 PM
Starting Member
1998 Chevrolet Blazer
Join Date: Jul 2012
Location: St. Louis
Posts: 134
Dadatone is on a distinguished road

Have you done a fuel pressure test on the truck? When was the last time you inspected your spark plugs? Are they clean, showing a lean burn or clogged?
1998 Chevy Blazer 2WD
171,000 miles
Stock, no modifications - yet.
Reply With Quote
Old 09-09-2012, 08:44 AM
Super Member
1999 GMC Jimmy
Join Date: Mar 2012
Location: Iowa
Posts: 1,024
50lb_cat will become famous soon enough

+1, also try cleaning the MAF sensor.
Reply With Quote
Old 09-09-2012, 03:07 PM
Beginning Member
1997 Chevrolet S-10
Join Date: Apr 2012
Posts: 29
viper1ex19 is on a distinguished road

Let me know when you figure this one out.

My truck has been sitting in the driveway for over a month with the same problem.

And YES it works; I made it come on by unplugging my MAF Sensor to make sure.

I have noticed when I first start it up it runs great for about a minute or two.
I mean it runs like a brand new one but after it sits there and idles for about 1 minute it seems like the timing is off or something and it will backfire if you crack the throttle open really fast.

I'm letting mine sit until I get some extra cash to go at it again.

I've replaced the following with mostly AC Delco or Delphi parts;

Fuel Pump
Fuel Filter
Fuel Injection Spider w/ new pressure regulator
Distributor Cap
Rotor Button
Spark Plugs
Plug Wires
Camshaft Position sensor
ECM- With a known good used one flashed to this trucks Vin#
Map Sensor
Idle Air Control Sensor
Throttle Position Sensor
EGR Valve
Purge Valve
Catalytic Converter

02 sensors
Crankshaft Position Sensor
Physical Timing (with dist cap off turn crank back and forth to get a approx degree)
Ignition Switch (connections/ground/hot)
Did the wire wiggle test to see if it made any difference when I wiggle the wires around

I don’t know where to go from here but when I figure it out I will post it because this seems o be a common problem with these aggravating little pains in my ***.
Reply With Quote
Old 09-09-2012, 04:45 PM
New Member
Join Date: May 2006
Posts: 4
awhoff is an unknown quantity at this point

well just got back in from the garage, plugs look great and my 95 does not have a MAF.
Replaced the fuel pump today because i had already bought it and have the same issue.
Idles fine, upon acceleration it lopes before it is willing to go.
The Hoff
Reply With Quote
Old 09-09-2012, 08:14 PM
Captain Hook's Avatar
1998 Chevrolet Blazer
Join Date: Mar 2009
Location: Belleville, Michigan
Posts: 7,672
Captain Hook is a jewel in the roughCaptain Hook is a jewel in the roughCaptain Hook is a jewel in the rough

viper1ex19, The OP has a 95 with CMFI, your 97 has CSFI: two totally different computer control and fuel injection systems requireing totally different diagnostics. Best if you start another thread, we can help you diagnose yours in that thread.
You have to know how it works,
to figure out why it doesn't.
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 Blazer idles rough and has hesitation Blazerdave95 2nd Gen S-series (1995-2005) Tech 8 09-02-2011 07:06 PM
4.3 engine hesitation issues magg383 2nd Gen S-series (1995-2005) Tech 2 02-16-2011 01:32 PM
1995 blazer has slight hesitation when accelerating. randy2009 2nd Gen S-series (1995-2005) Tech 0 07-22-2010 07:38 PM
1995 bad hesitation ses came on shesrdy2laff Engine & Transmission 0 05-13-2010 08:55 PM
hesitation issues Numba1Sean 2nd Gen S-series (1995-2005) Tech 41 05-27-2009 09:55 PM

1995, 95, acceleration, bad, blazer, common, fix, ground, hesitate, hesitation, oil, pressure, problems, s10, switch

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -5. The time now is 07:21 AM.