Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Closed Thread
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-05-2011, 05:22 PM
Beginning Member
 
Join Date: Sep 2009
Posts: 36
blazer chris is on a distinguished road
Default 1997 blazer 4.3 with rough idle and stumble off idle

Hello,
I need feedback, this is what has happened i first had a cyl 5 missfire and it was a bad missfire ( you could really feel it code p0305 i believe) and all of a sudden it went away ran great , i cleared the codes.Then i get a real bad missfire again this time it said cylinder 3 missfire i changed the plugs and they were clean and not fouled !!!So after hearing about these spiders on these motors i decided to replace it , well i dont have the bad missfire anymore and runs relatively good except for the idle it kinda oscillates and feels like it is losing a plug once in a while !! It used to run great before all this started happening . Here is the new parts i have thrown at it - ac/delco fuel pump yesterday pressure was 52# before now it has 56 -60 key on engine off !! new spider (standard motor unit updated model) new ac/delco plugs,wires,cap,rotor,fuel filter !! Today i got a p0303 code again after it idled for like 15 minutes!! here is some data i collected before the light came on (sorry i dont have the freeze frame data at code set)
mil status- off & idle was 586-615 & maf lb/m is 9.7to 10.00 coolant was 189 & iat is 75 & ign adv is 16.5 to 24& st ftrm1 is 0 to 2.3 & lt ftrm 1 is steady at .8 & o2 reading is fluctuating from .050 to 890 !! The thing i see that looks LOW is the map hg reading(if that is the vacuum reading)??? PLEASE CHIME IN !!!!! IM AT MY LAST NERVE WITH THIS TRUCK....
  #2  
Old 12-08-2011, 09:56 AM
Beginning Member
 
Join Date: Sep 2009
Posts: 36
blazer chris is on a distinguished road
Default

Update i put the vehicle on the tech2 and saw missfires on cyl 3 mostly and then cyl 4 and then misc other cylinders , i think i have a distributor issue so thats gonna be ordered,,,,let you know what happens
Old 12-08-2011, 09:56 AM
 
 
 
Closed Thread

Tags
1997, 43, 97, adjust, blazer, forum, ftrm1, gm, idle, idol, lt, misfire, reading, readings, rough, set, vacuum, vlazer


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough idle... Dies at idle... No power Chevrolet.Love Engine & Transmission 0 08-19-2011 09:05 PM
1997 Bravada - Slight Rough Idle, runs great - HELP demian5 2nd Gen S-series (1995-2005) Tech 2 03-07-2010 09:00 AM
Bogging down when at idle/ Rough Idle solution 97BLAZE4X4 2nd Gen S-series (1995-2005) Tech 1 02-07-2010 07:33 PM
Rough Idle Misfire P0300/P0305 -1997 vaportrail 2nd Gen S-series (1995-2005) Tech 6 08-16-2009 06:15 PM
Stumble at idle. 94NDTA 1st Gen S-series (1983-1994) Tech 3 09-25-2008 09:51 PM

Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 09:11 AM.

Internet Brands, Inc.