Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-27-2010, 10:45 PM
Starting Member
 
Join Date: Jun 2010
Location: Inland Empire, CA
Posts: 1
B. Vader is on a distinguished road
Default 2001 Blazer Error Code P0304

First off Hi, and thank you! I have a 2001 Chevy Blazer LS 4-door 4x4x4. I bought it about 4 years ago used in great condition. While moving down here to CA from CO I decided doing 90 with a U-Haul would be a great idea, right? Yeah... young dumb and kicking myself in the rear ever since. Blew the radiator, and due to continued use while it wasn't running quite right I ended up completely warping the heads. It took 2 years after that all for me to save up enough money (and my new wife kicking my rear at the time for a family hauler) so I could take it to a engine rebuilding facility. I paid them $2600 to get back my blazer, completely 'fixed'. I didn't even drive it off the lot before I noticed a cylinder misfiring. They said it was a combination of bad injectors, wires, cap and rotor. I've now replaced them all, but continue to get an error P0304. I've checked compression and it's good, spark plug wear is nominal, but I replaced them and it still show's the same wear (normal). The new injector is the upgraded one, the cap and rotor are the duralast gold, as are the wires. I'm at a loss for what I need to do to get this thing up and running... Help me PLEASE!! I also show error codes P0135 and P0452... O2 sensor bank 1 sensor 1 and a low pressure EVAP. Would either of those matter for the missing? Thanks guys!!
__________________
2001 Chevy Blazer 4x4x4 "Family Hauler"
1976 Chevy Nova 2-dr 383 Stroker, The "Toy"
Reply With Quote
Old 06-27-2010, 10:45 PM
 
 
 
Reply

Tags
03, 2001, 97, blaser, blazer, chevrolet, chevy, code, codes, error, evap, list, p0304, paint, trailblazer


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 05:42 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.