4WD button blinking but NO 4WD '99 Blazer - Blazer Forum - Chevy Blazer Forums

Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech

Closed Thread
LinkBack Thread Tools Search this Thread
Old 10-26-2010, 09:41 AM
New Member
Join Date: Oct 2010
Posts: 3
ttwo is on a distinguished road
Default 4WD button blinking but NO 4WD '99 Blazer

My 4WD has always woked and yesterday went to switch (on the dash) from 2WD to Auto 4WD or 4WD and it won't complete the transfer. The light will simply blink for about 30 sec and then go back to 2WD. Could this be a low transfer case oil level?

I did stop and switch to 2WD Lo and it switches the transmission but I'm not certain that it is in 4WD as the 2WD light also stays blinking. Things seem to click like they used to, but it doesn't complete the transfer by having a solid 4WD light. And I do not get 4WD to the wheels.

Any thoughts? I have a '99 Blazer ZR2

ADDED: I also note that my AC/heat is stuck in the vent mode...does this make a vaccume leak more likely? Where should I start to look?

Last edited by ttwo; 10-26-2010 at 09:56 AM.
Old 10-26-2010, 11:03 AM
ZR2Daddy01's Avatar
New Member
2001 Chevrolet Blazer
Join Date: Apr 2010
Location: Liverpool NY
Posts: 65
ZR2Daddy01 is on a distinguished road

I'd start at the solenoid on the firewall, probably need somebodys help to hit the 4wd button to see if it switches. It has a hole in the bottom that sucks air through it in 2wd and it will stop in 4wd cause it redirects the vacuum to the actuator. If thats ok next try the actuator (its under the battery) to see if its stuck or possibly has a torn bladder. I've had all the common blazer 4wd problems and its never effected my heat control vacuum.
Old 10-26-2010, 01:15 PM
New Member
Join Date: Oct 2010
Posts: 3
ttwo is on a distinguished road

yeah basically my air blower works to blow air but I can't direct where the circulating air goes. It comes essentially out of the vents, floor vent and window vents all the time.

That's why I think that they may be tied to the same problem as both require vacuum.!
Old 10-28-2010, 01:35 PM
New Member
Join Date: Oct 2010
Posts: 3
ttwo is on a distinguished road

Found the problem, simply a vacuum line unplugged. Fixed both problems!!
Closed Thread

Similar Threads
Thread Thread Starter Forum Replies Last Post
4Hi constantly blinking but not shifting out Mike_Williams7 Steering, Suspension & Drivetrain 0 02-10-2015 08:29 AM
Will a transmission np236(4 button) transfer case fit np233 (3 button) transfer case Flyfishen Engine & Transmission 3 01-24-2014 08:27 PM
4x4 Dash Switch: 3 Button vs. 4 Button 762mm 2nd Gen S-series (1995-2005) Tech 14 12-07-2012 05:13 AM
4x4 not engaging button keeps blinking - please help greatwhite Steering, Suspension & Drivetrain 1 10-24-2010 03:27 PM
99 blazer 4hi does not stop blinking when trying to engage 4wd. tambo 2nd Gen S-series (1995-2005) Tech 5 03-04-2005 06:44 PM

2000, 2001, 4wd, 99, auto, blazer, blinking, blinks, button, chevy, clicking, drive, flashing, light, swith, wheel

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -5. The time now is 02:01 PM.