Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-04-2012, 07:23 AM
Starting Member
 
Join Date: Sep 2012
Posts: 107
tdbone1 is on a distinguished road
Exclamation brake lights on passenger side only

i have a 1999 s10/blazer ls 4x4

the drivers side rear brake lights do not work and the passenger side does
i took out the bulbs from the passenger (the top and middle bulbs (both are 3057)) and put them in the drivers side and they still did not work.
the bulbs i took out of the drivers side and put in the passenger side did work so for sure it is not the bulbs.

i pulled up a wiring schematic and it shows there is a fuse for the left side and right side but it dont show where they are located and im not really sure if it is true after what i have been reading.

to my understanding this could be in the turn signal switch / multi function switch.

so my question is...
is there a seperate left and right fuse for the rear brake lights?
what is the best way to see if its the multi function switch or hazard light switch?
if it is a bad multi function switch or hazard switch is it really that hard to replace by yourself?

i have replaced turn signal switch assembly in 85 camaro before with a steering wheel puller.
it cant be to hard can it?

i searched the forums for brake light but i couldnt find an answer for one side not working only.

thanks

just wanted to add:
all the rear lights are working perfect (even on the left side)
just no brake lights on left side
blinkers work
park lights work
turn signals work
flashers work
reverse lights work

strange note:
if i depress the brake pedal and then put my turn signal into the turn right position the left brake light does light (both upper and lower bulbs)

thanks

im almost for sure it is the multifunction switch so no need to reply to this thread

Last edited by tdbone1; 10-05-2012 at 11:30 AM.
Reply With Quote
  #2  
Old 10-05-2012, 02:54 PM
Starting Member
2002 Chevrolet Blazer
 
Join Date: Jul 2010
Location: New York
Posts: 100
Franco is on a distinguished road
Default

Don't hold me to this completely... but I have a vague memory of a splice point where the wiring splits to the L&R brake lights in the rear of the vehicle. Pop off the plastic trim on the bottom of the tailgate opening and poke around in there.

Wish I could be more specific, but it's worth a look...
Reply With Quote
  #3  
Old 10-05-2012, 03:36 PM
Senior Member
 
Join Date: Sep 2008
Location: Snow Hill MD
Posts: 733
step66 is an unknown quantity at this point
Default

No 'cause the wiring for the rear lamps doesn't enter the tailgate. But Franco you are on the right track, as I think that you're right about a L to R split back there,but I think its under the vehicle,if my Jimmy was here I'd go look but the wife has it! I have been hesitant to reply to this because I don't think its the multi function switch at all...IMO
Reply With Quote
  #4  
Old 10-05-2012, 04:13 PM
richphotos's Avatar
Moderator
1993 GMC S-15
 
Join Date: Dec 2011
Location: Minneapolis, MN
Posts: 3,912
richphotos is a jewel in the roughrichphotos is a jewel in the roughrichphotos is a jewel in the rough
richphotos1
Send a message via AIM to richphotos Send a message via MSN to richphotos Send a message via Yahoo to richphotos
Default

First things first, test to make sure you are getting power at the sockets.
__________________
1993 GMC Jimmy S15 SLT
4.3L Vortec
Digital Dash, keyless entry, leather and power everything
Reply With Quote
  #5  
Old 10-05-2012, 06:29 PM
97cherryblazer's Avatar
Super Member
1997 Chevrolet Blazer
 
Join Date: Sep 2010
Location: Lynnwood WA
Posts: 1,485
97cherryblazer will become famous soon enough97cherryblazer will become famous soon enough
Default

So to make it clear, your left lights work fine when you have the left turn signal, hazards and driving lights on?? and only dont work when you hit the brakes?? i think some people are confused about that
__________________
97 Blazer 4x4 4Dr
2" Body Lift, 31" DuraTracs, Steel Bumper, Spare Tire Carrier
Reply With Quote
  #6  
Old 10-05-2012, 10:15 PM
Beginning Member
 
Join Date: Mar 2010
Location: Texas
Posts: 37
thundergod66 is on a distinguished road
Send a message via Yahoo to thundergod66
Default

Quote:
Originally Posted by tdbone1 View Post
i have a 1999 s10/blazer ls 4x4

the drivers side rear brake lights do not work and the passenger side does
i took out the bulbs from the passenger (the top and middle bulbs (both are 3057)) and put them in the drivers side and they still did not work.
the bulbs i took out of the drivers side and put in the passenger side did work so for sure it is not the bulbs.

i pulled up a wiring schematic and it shows there is a fuse for the left side and right side but it dont show where they are located and im not really sure if it is true after what i have been reading.

to my understanding this could be in the turn signal switch / multi function switch.

so my question is...
is there a seperate left and right fuse for the rear brake lights?
what is the best way to see if its the multi function switch or hazard light switch?
if it is a bad multi function switch or hazard switch is it really that hard to replace by yourself?

i have replaced turn signal switch assembly in 85 camaro before with a steering wheel puller.
it cant be to hard can it?

i searched the forums for brake light but i couldnt find an answer for one side not working only.

thanks

just wanted to add:
all the rear lights are working perfect (even on the left side)
just no brake lights on left side
blinkers work
park lights work
turn signals work
flashers work
reverse lights work

strange note:
if i depress the brake pedal and then put my turn signal into the turn right position the left brake light does light (both upper and lower bulbs)

thanks

im almost for sure it is the multifunction switch so no need to reply to this thread

i had the same prob..i have a 2000 chevy blazer..its the turn signal switch..theres a recall on it,might wanna check into it..i replaced mine twice.. only had brake light on pass side but when i barely move the turn signal switch up it would come on then it turn off..all chevy blazer had a problem with this but i can bet you its the turn signal switch..but check with the dealer for the recall..
Reply With Quote
  #7  
Old 10-05-2012, 10:18 PM
Starting Member
2002 Chevrolet Blazer
 
Join Date: Jul 2010
Location: New York
Posts: 100
Franco is on a distinguished road
Default

Just occurred to me... I seem to remember finding the splice point when repairing the center brake light. Does yours work?
Reply With Quote
  #8  
Old 01-27-2013, 12:07 AM
New Member
 
Join Date: Mar 2012
Posts: 3
Moto491 is on a distinguished road
Default

Hi. I have a 1999 blazer with the same problem. The brake lights on the drivers side would work sometimes then would not work .Passenger side aand 3rd brake lights work fine. In fact they are not working now for the past two days as i was out in the cold checking the wires by the tail light today. the splice point you speak about is located inside the jack compartment. I have parking lights,turn signal,hazards and back up lights . Just no brake lights on the drivers side when i press on the brakes.I will try and move the turn signal switch slightly and press on the brakes to see if that is the problem like the one poster said above tommorow since its dark out now. Also a problem with the ABS light going on and the ABS going off for no reason and the light comes on.Then its off when i start it again. Both front wheel bearings were just replaced but the light still comes on as it did before i had them fixed.. I thought this may have something to do with the brake lights.. I scanned the truck with a code reader and no codes stored. I guess the reader i have does not read ABS codes. Before i go and order a ABS code reader i figure i would wait to see what you think first. thanks guys
Reply With Quote
  #9  
Old 01-27-2013, 12:28 AM
nunya's Avatar
Starting Member
1998 Chevrolet Blazer
 
Join Date: May 2012
Location: Pgh PA
Posts: 231
nunya is on a distinguished road
nunyaWD21
Default

I recently went through this with a 2000 Blazer at work, bulbs were all good, all lights functioned correctly except the left brake light. Ended up it was actually the "combination flasher"
Click the image to open in full size.
located here behind the glovebox
Click the image to open in full size.

Someone was chasing it as well as it had a new turn signal switch and you could see where wires were stripped back for hooking jumper leads
Reply With Quote
  #10  
Old 01-27-2013, 01:36 PM
Beginning Member
 
Join Date: Mar 2010
Location: Texas
Posts: 37
thundergod66 is on a distinguished road
Send a message via Yahoo to thundergod66
Default

hopefully it be the same set up..
Reply With Quote
Old 01-27-2013, 01:36 PM
 
 
 
Reply

Tags
1999, 2002, abbreviation, brake, brakes, fuse, gmc, left, light, lights, off, passenger, s10, side, turn


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
***headlights not working on passenger side/yellowish dim lights busta7600 Lighting & Electrical 3 08-28-2012 12:14 PM
Passenger side of 99 blazer sits alot lower then drivers side ? upmaine 2nd Gen S-series (1995-2005) Tech 2 07-09-2012 12:31 PM
passenger side window won't go down 408blazer 1st Gen S-series (1983-1994) Tech 3 06-09-2012 11:04 PM
passenger side wheel guywm25 2nd Gen S-series (1995-2005) Tech 2 08-14-2008 08:33 AM
Flasher Clicking under passenger side dash, stops when you press brake pedal??? apekim 2nd Gen S-series (1995-2005) Tech 12 09-15-2007 10:46 AM

Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 04:11 PM.

Internet Brands, Inc.