Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-02-2010, 02:17 PM
Beginning Member
 
Join Date: Nov 2009
Location: chicago, IL
Posts: 12
noseback is on a distinguished road
Default driver power seat off track?

hey guys, quick question.. the power seat on my 95 s10 blazer isn't working as it should, for instant the seats motor works, it will raise and lower the seat, the recliner is manual and it works too, i just can't move the seat forward or backward, i noticed one side is either locking up or might be off track. as i try to move it forward only the left side of the seat would move but the right side doesn't budge, any clue on how i can go about this?
Reply With Quote
  #2  
Old 03-02-2010, 02:35 PM
swartlkk's Avatar
Administrator
2009 GMC Yukon Denali
My Garage
 
Join Date: May 2005
Location: Waterloo, NY
Posts: 36,911
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Send a message via ICQ to swartlkk Send a message via AIM to swartlkk
Default

There is a drive cable that connects one side to the other. That is most likely broken or pulled off. I believe that it has been covered in at least one other thread on the forum. If memory serves me, that thread had pictures and possibly even a part number.
Reply With Quote
  #3  
Old 03-03-2010, 08:10 PM
New Member
 
Join Date: Aug 2009
Posts: 72
jjnemoiii is on a distinguished road
Default

No surprise Swartlkk remembered the thread and possible picture...
http://www.blazerforum.com/forum/sho...at+drive+cable
__________________
2001 Blazer 4x4
Reply With Quote
Old 03-03-2010, 08:10 PM
 
 
 
Reply

Tags
98, blazer, broke, cable, chevy, drive, electric, number, part, power, problems, seat, side, track, works


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 01:47 AM.

Internet Brands, Inc.