Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-12-2010, 11:09 PM
New Member
 
Join Date: May 2009
Location: buffalo, ny
Posts: 55
toaks1 is on a distinguished road
Default Rear Brakes - Seizing, replacing calipers and bleeding

Hi all,

I need some advice here

Ive got an 00 jimmy, 4x4, 124k miles

I have sticky rear brakes, i checked it out and found that one of the driver's side caliper slides was sticking. So I took the slider out, cleaned it up with an abrasive wheel re-greased it and put on some new pads.
I did the same on the passenger's side (although neither slide was stuck or seized).

What i noticed after putting the new pads on is that the calipers only slid about 1/4" to 1/2" back and forth with the new pads. The caliper pistons were retracted as far as I could get them and they looked like they were fully retracted. Is this normal?

Anyways, i smell brakes really bad now and the both rear wheels seem to get pretty warm after driving for a while. So im thinking that my calipers are not retracting all the way. I am not 100% sure of this though because the pistons were not too difficult to compress with the c-clamp, maybe slightly harder than i would have expected but they didnt require excessive force. Any other ideas or common problems which would cause a slow or sticky caliper?

Also, if the final verdict is to replace the calipers then I need to know the bleeding procedure if I replace both calipers, and the across the axle brake line (because it is getting a bit rusty and might as well do it while i'm at it). Will i need to bleed the whole system? I have only replaced my front calipers one at a time and I bled them one at a time, which was pretty easy.

Any advice, tips, tricks, do's and dont's are greatly appreciated.

Thanks in advance

Last edited by toaks1; 01-12-2010 at 11:15 PM.
Reply With Quote
  #2  
Old 01-13-2010, 07:13 AM
DriftinBlzr's Avatar
New Member
 
Join Date: Jul 2009
Posts: 78
DriftinBlzr is on a distinguished road
Default

Did you clean where the brake pads' tabs go in the caliper bracket? Sometimes the pads themselves hang up and not the caliper. There are some thin shims that can get a little crusty. When I replaced my pads last time, I cleaned them really good and then spread on some anti-seize.

Also if you don't replace the hard brake line but just the calipers get a set of fluid hose clamps. You can pinch off the rubber line between the caliper and hard line and cut down on the amount of air that can get into the system.

Click the image to open in full size.

Later, Doug
Reply With Quote
  #3  
Old 01-13-2010, 07:53 AM
New Member
 
Join Date: May 2009
Location: buffalo, ny
Posts: 55
toaks1 is on a distinguished road
Default

the pads were sliding nicely inside of the caliper bracket, and i did dab the ends with anti-seize so that they dont get stuck.

I was fooling around this morning in a parking lot. I put the truck in neutral and pressed teh brake pedal as hard as I could then i let the pedal go and immediately shifted into drive, the truck would not roll under it's own power (without tapping the gas). I waited a few minutes then lightly pressed teh brake and shifted into reverse and then drive, it rolled freely without giving any gas.
From this i concluded taht the calipers are eventually releasing, but they are just slow to release. This is leading me to believe that possibly the flexible tube feeding the rear brake line is collapsing, is this a safe assumption?

Last edited by toaks1; 01-13-2010 at 07:56 AM.
Reply With Quote
  #4  
Old 01-13-2010, 03:14 PM
Junior Member
 
Join Date: Dec 2008
Location: Wading River, NY (Long Island)
Posts: 365
Tony H is an unknown quantity at this point
Default

I just went through this same thing about 2 months ago.

Just eyeballed the rear Brakes before my daughter took a long trip. The brake pads were real low. Bought new pads, went to put them on and the rear caliper pistons retracted but with a little more force then they should have. Since I never did rears on a Blazer I thought it was normal. One of the Sliders was rusted in place so I bought a new Bracket and Sliders. I thought we were all good.. took it for a test ride the rear Wheels were hot and I could smell brakes.
Ended up replacing both Calipers. All good now.
I'm betting there is rust on the Pistons and it's causing some drag and the piston isn't pulling back enough when you release the brake.
I have heard of this Collapsing soft lines from other people but I have had a lot of old cars and I have never seen this happen personally.

Make sure the Brake reservoir is full before swapping out the calipers so you don't have to purge the Master.
OR have someone step lightly on the brake pedal as you swap out the Caliper, that will prevent fluid from flowing out of the Master and reservoir.
New Calipers. before installing, take out Bleeder and put anti seize on the threads. makes it easier to loosen them in the future
__________________
This '99 Blazer is my daughters.
It's the Newest car we own. I'm used to seeing Valve covers , not Wire looms everywhere.
Other vehicles in the stable:
1975 Jeep CJ5 Bought in 1980 Chevy powered fiberglass body I did the work
1985 Chevy Stepside Pickup// Original owner 298K miles
1989 Volvo 244 //Original owner 305K miles
1991 Ford Explorer Bought for $450 w/182K miles it now has 336K miles on it.
http://home.lyse.net/brox/TonyPage4.html

Last edited by Tony H; 01-13-2010 at 03:21 PM.
Reply With Quote
  #5  
Old 01-16-2010, 06:13 PM
New Member
 
Join Date: May 2009
Location: buffalo, ny
Posts: 55
toaks1 is on a distinguished road
Default

OK, well today I attempted to fix my rear brakes! I swapped both calipers out and bled them, thought i was good.

I took it for a spin and the pedal was real weak. The "brake" light on the dash is on. I then came to find out that I accidentally put them on backwards, I forgot that the bleeder screw had to be facing UP

So i went and swapped them around, so now they are on there correctly. BUT now when i go to bleed the rear brakes I am not getting ANY fluid to the rear, so I am not building any hydraulic pressure back there.

Does anybody have any idea why i am not getting any pressure or fluid to the rear? I do not have any leaks in the line before the rear, so I cannot figure out why im not getting anything. I really hope that I didnt FUBAR something.

Also, I never let the fluid level drop in the reservoir when bleeding I made sure to keep it full.
If I dont hear back from anyone tonite I am goin to goodyear in the morning to get the whole system flushed & bled in the morning. Its $89 I dont wanna spend but i have no clue here!!

Last edited by toaks1; 01-16-2010 at 06:16 PM.
Reply With Quote
  #6  
Old 01-16-2010, 09:06 PM
Junior Member
 
Join Date: Apr 2006
Location:
Posts: 467
RonJon is an unknown quantity at this point
Default

Try bleeding the front brakes. (that is open a front caliper and push the brake pedal) There's a pin in the proportioning valve that slides over and shuts off the brakes on front or rear if you blow a line so you have some sort of brakes. With no resistance from the empty caliper it moved, by removing front resistance you might be able to balance it again.
__________________
2000LT Blazer 4x4
Reply With Quote
  #7  
Old 01-16-2010, 09:25 PM
New Member
 
Join Date: May 2009
Location: buffalo, ny
Posts: 55
toaks1 is on a distinguished road
Default

Ron, should i try this with the motor running or with the motor off?
Reply With Quote
  #8  
Old 01-16-2010, 10:34 PM
Junior Member
 
Join Date: Apr 2006
Location:
Posts: 467
RonJon is an unknown quantity at this point
Default

Motor off. No need for boost
__________________
2000LT Blazer 4x4
Reply With Quote
  #9  
Old 01-17-2010, 02:15 PM
New Member
 
Join Date: May 2009
Location: buffalo, ny
Posts: 55
toaks1 is on a distinguished road
Default

got it taken care of today, i have a good pedal now.

I tried messing around with one of those vacuum pump pieces of crap from advanced auto and ended up wasting several hours.
i found that the best way to bleed when working alone is to just fill up a glass jar with clean fluid, put a hose in it, put that hose on the bleeder, crack the bleeder and pump the brake pedal by hand several times while looking at the jar. You will pull some fluid back in when u let the pedal go, but as long as it is clean fluid it doesnt matter, and the air will eventually work its way out.
This is way easier than the pump, open bleeder, release pedal, repeat method; or using one of those lousy vacuum tools
Reply With Quote
  #10  
Old 01-18-2010, 07:47 AM
Junior Member
 
Join Date: Dec 2008
Location: Wading River, NY (Long Island)
Posts: 365
Tony H is an unknown quantity at this point
Default

Quote:
Originally Posted by toaks1 View Post
got it taken care of today, i have a good pedal now.

I tried messing around with one of those vacuum pump pieces of crap from advanced auto and ended up wasting several hours.
i found that the best way to bleed when working alone is to just fill up a glass jar with clean fluid, put a hose in it, put that hose on the bleeder, crack the bleeder and pump the brake pedal by hand several times while looking at the jar. You will pull some fluid back in when u let the pedal go, but as long as it is clean fluid it doesnt matter, and the air will eventually work its way out.
This is way easier than the pump, open bleeder, release pedal, repeat method; or using one of those lousy vacuum tools
ABSOLUTELY. I've done this for years. Depending on how long the hose is, the first press on the pedal might let some air back into the brake line but after that, the fluid in the jar and in the hose act as a Check valve.
You just need enough fluid in the jar to submerge the end of the hose.

Glad you got it all purged and working nice
__________________
This '99 Blazer is my daughters.
It's the Newest car we own. I'm used to seeing Valve covers , not Wire looms everywhere.
Other vehicles in the stable:
1975 Jeep CJ5 Bought in 1980 Chevy powered fiberglass body I did the work
1985 Chevy Stepside Pickup// Original owner 298K miles
1989 Volvo 244 //Original owner 305K miles
1991 Ford Explorer Bought for $450 w/182K miles it now has 336K miles on it.
http://home.lyse.net/brox/TonyPage4.html
Reply With Quote
Old 01-18-2010, 07:47 AM
 
 
 
Reply

Tags
2002, 98, 99, back, blazer, bleed, brake, brakes, caliper, change, procedure, rear, sticking, warm, wheel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 07:44 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.