Rear Wiper not working/Noise??? - Blazer Forum - Chevy Blazer Forums

Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech

Closed Thread
LinkBack Thread Tools Search this Thread
Old 10-13-2011, 06:20 PM
New Member
Join Date: Oct 2011
Location: Wisconsin
Posts: 6
IrishDrums85 is on a distinguished road
Talking Rear Wiper not working/Noise???

Hi Guys,

I have a 1998 2dr with the drop gate/lift window. I got this blazer at the end of last winter. The rear wiper doesnt work, wont even move, however i get a loud buzzing noise from inside the tailgate...And its sometimes spurratic. The switch is off and it'll still buzz, normally when i press the brakes. I unplugged the switch @ the dash, that didnt stop the buzz, so i unplugged the motor in the gate, and that worked.

Can i fix this by changing out the motor, or is there anything else that could be causing the buzz, like a relay or something? Checked the other threads, old, and no soultions that involve it working again haha...Thanks!

FYI, the rear latch button works fine.
Old 11-29-2011, 03:52 PM
Beginning Member
Join Date: Apr 2011
Posts: 10
elkhntr88 is on a distinguished road

The buzzing noise is the motor gears slipping inside the housing. Changing out the motor should fix your problem and it only takes about an hour.
Old 11-30-2011, 11:56 AM
onder's Avatar
Starting Member
2000 Chevrolet Blazer
Join Date: Oct 2010
Location: moline,il
Posts: 102
onder is on a distinguished road
onder badur

I suggest check the wiper arm too sometimes the teeth inside the wiper that connects to the motor get worn out and causes to motor to slip inside the arm.
2000 2dr Blazer 4x4
Closed Thread

Similar Threads
Thread Thread Starter Forum Replies Last Post
working. not working. working Lighting & Electrical 0 03-20-2014 11:26 PM
Wiper arm dangling, other wiper arm working Helter80 2nd Gen S-series (1995-2005) Tech 2 06-14-2013 09:34 PM
Rear wiper not working...dash switch and motor issues babeba67 2nd Gen S-series (1995-2005) Tech 3 01-08-2013 09:03 PM
Rear wiper not working darklink 2nd Gen S-series (1995-2005) Tech 7 06-16-2012 04:35 PM
93 s10 blazer 4 door rear wiper not working even after fixing wire. ussexplorer Lighting & Electrical 8 06-08-2011 09:14 PM

1995, 2000, back, blazer, buzz, chevy, doesnt, forum, noise, quit, rear, stoped, wiper, work, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -5. The time now is 01:57 PM.