Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-26-2012, 04:48 PM
New Member
 
Join Date: May 2012
Location: Orlando FL
Posts: 6
blazextreme is on a distinguished road
Default Rough idle and bad mileage. Ideas?

2003 Blazer xtreme (4.3 - 6 cylinder). I bought this about 4 months ago. Been slowly going through it and fixing problems that the previous owner just let go. It did have a check engine light but that was related to the previous owner removed the cat converter. Replaced that and a O2 sensor and been check engine light free for months.

I noticed that the engine isn't running smooth. Shakes even a little. At idle after warmed up you can really notice it. Also noticed the fuel mileage sucks. I go about 100 miles in 4 days and go through almost between half a tank and 3/4s. So I am down to about a quarter tank for 100-120 miles.

I am going to replace plugs and wires, cap etc... but what else could it possibly be? Before I dump money throwing parts at it. No codes being thrown....

ALSO - is the evaporator drain just a tiny hole about the size of a quarter inch at the bottom? No hose? I am leaking on my passenger floor and that is the only hole I can see... and doesn't seem to be obstructed.

Thanks!

Click the image to open in full size.
Reply With Quote
  #2  
Old 08-26-2012, 05:25 PM
Rottidog's Avatar
BF Veteran
2002 Chevrolet Blazer
 
Join Date: Sep 2008
Location: Winnipeg, Manitoba
Posts: 2,514
Rottidog has a spectacular aura aboutRottidog has a spectacular aura about
Send a message via MSN to Rottidog Send a message via Yahoo to Rottidog
Default

1st off please don't use any electrical components like the dist, plugs, rotor etc that aren't AC Delco or Delphi. These vehicles are uber picky about that for some reason.
Has the MAF been cleaned lately? Vacuum lines are all in good condition, not cracked etc & hooked up? Air intake temp sensor is hooked up in the intake tube off the air filter? Air filter is clean? Have you ran any sort of injector cleaner through it or that Chevron fuel system cleaner our admin Kyle likes to use & recommends?
Nice extreme & welcome to forum btw!
__________________
'02 Blazer 2dr. 4x4
Supercharged, Marine Intake & Bosch Injected
Cammed
Lifted
Modified
Wolf Performance dynotuned PCM www.wolfperformance.com/about.html#Title1 <-- look at that resume & tell me you'd be uncomfortable with him working on your vehicle.
www.photobucket.com/albums/dd486/Rottidog/CB%20The%20Cranberry%20Blazer%20_GF%20made%20up%20 the%20name_/
YouTube http://www.youtube.com/watch?v=Bl0YwGxOJms&feature=plcp
Reply With Quote
  #3  
Old 08-26-2012, 05:43 PM
spittybays
Guest
 
Posts: n/a
Default

+1 on all Rotti said and add a clean-up on the egr with an updated gasket with a screen.
That should keep you busy for a bit. Somebody just started a string on smelly AC and there was some stuff on cleaning the drain. Not too far back.
Reply With Quote
  #4  
Old 08-26-2012, 06:05 PM
Rottidog's Avatar
BF Veteran
2002 Chevrolet Blazer
 
Join Date: Sep 2008
Location: Winnipeg, Manitoba
Posts: 2,514
Rottidog has a spectacular aura aboutRottidog has a spectacular aura about
Send a message via MSN to Rottidog Send a message via Yahoo to Rottidog
Default

A 2003 shouldn't have an EGR. They were weeded out midway 2002.
As for the A/C I remember that post now smitty. Captain Hook told the OP how to clean it.
Check out HVAC Adventures &

Bad smell from ac ??? Please help <--- that's the one.
__________________
'02 Blazer 2dr. 4x4
Supercharged, Marine Intake & Bosch Injected
Cammed
Lifted
Modified
Wolf Performance dynotuned PCM www.wolfperformance.com/about.html#Title1 <-- look at that resume & tell me you'd be uncomfortable with him working on your vehicle.
www.photobucket.com/albums/dd486/Rottidog/CB%20The%20Cranberry%20Blazer%20_GF%20made%20up%20 the%20name_/
YouTube http://www.youtube.com/watch?v=Bl0YwGxOJms&feature=plcp
Reply With Quote
  #5  
Old 08-26-2012, 06:27 PM
spittybays
Guest
 
Posts: n/a
Default

That is a shame. I love the looks I get at a stop sign when I jump out and whack that thing with an extension and hammer for no particular reason.
Reply With Quote
  #6  
Old 08-26-2012, 07:28 PM
Rottidog's Avatar
BF Veteran
2002 Chevrolet Blazer
 
Join Date: Sep 2008
Location: Winnipeg, Manitoba
Posts: 2,514
Rottidog has a spectacular aura aboutRottidog has a spectacular aura about
Send a message via MSN to Rottidog Send a message via Yahoo to Rottidog
Default

LMAO!!!
Like when I kick my tires to "reset" the counter balance beads.
__________________
'02 Blazer 2dr. 4x4
Supercharged, Marine Intake & Bosch Injected
Cammed
Lifted
Modified
Wolf Performance dynotuned PCM www.wolfperformance.com/about.html#Title1 <-- look at that resume & tell me you'd be uncomfortable with him working on your vehicle.
www.photobucket.com/albums/dd486/Rottidog/CB%20The%20Cranberry%20Blazer%20_GF%20made%20up%20 the%20name_/
YouTube http://www.youtube.com/watch?v=Bl0YwGxOJms&feature=plcp
Reply With Quote
  #7  
Old 08-26-2012, 11:20 PM
New Member
 
Join Date: Aug 2012
Posts: 63
Presti7 is an unknown quantity at this point
Default

Chevy TSB #02-06-04-059

The plastic timing cover on the 4.3's are WARPING, throwing the crank sensor off. If your tach is going crazy then your crank is actually hitting the sensor.

12565102 is the GM part number for the 2 shims. One is .5 mm and the other 1mm. Some are requiring both spacers.

GM should mail everybody about this...this may be your problem too.
Reply With Quote
  #8  
Old 08-29-2012, 05:35 PM
New Member
 
Join Date: May 2012
Location: Orlando FL
Posts: 6
blazextreme is on a distinguished road
Default

Well I took it in to my mech as I don't have the time lately.

He pulled a couple spark plugs and said they looked great. Wires and cap/rotor are all good too. He ran it with his computer hooked up and said everything looks normal. Says he can't find anything out of the sort, and that maybe it's just the 4.3 is kinda a fuel hog and with all the ethanol in the gas that's not helping either. So he ran a 3 stage injector cleaner. He only charged me for that - good guy.

He did note that my evap drain is fine. I have a leak inbetween the housing and the firewall, and that's where I am getting rundown. Guess I need to pull the dash to fix this?
Reply With Quote
  #9  
Old 08-30-2012, 04:32 AM
97cherryblazer's Avatar
Super Member
1997 Chevrolet Blazer
 
Join Date: Sep 2010
Location: Lynnwood WA
Posts: 1,485
97cherryblazer will become famous soon enough97cherryblazer will become famous soon enough
Default

Well your gas mileage isnt right for sure.. I would clean you MAF like rotti said, it doesnt take long at all, and the other thing i would look into checking is the fuel pressure because if you have a leak in the spider injectors that will cause rough idle and bad mileage as well. Pressure should be 60+ with key at run and the engine OFF and it should stay at or above 55 for 10 minutes.
__________________
97 Blazer 4x4 4Dr
2" Body Lift, 31" DuraTracs, Steel Bumper, Spare Tire Carrier
Reply With Quote
  #10  
Old 08-30-2012, 05:03 AM
Super Member
1999 GMC Jimmy
 
Join Date: Mar 2012
Location: Iowa
Posts: 1,024
50lb_cat will become famous soon enough
Default

^^^, +1 on the MAF and checking fuel pressure and leakdown.
Reply With Quote
Old 08-30-2012, 05:03 AM
 
 
 
Reply

Tags
2003, 56, ac, blazer, blazerforum, chevy, code, due, idle, idling, miss, rough, runing, smoothly, stumbles, transmission


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
rough cold start idle and rough running blazerguy22 2nd Gen S-series (1995-2005) Tech 10 11-15-2013 12:50 AM
1997 blazer 4.3 with rough idle and stumble off idle blazer chris 2nd Gen S-series (1995-2005) Tech 1 12-08-2011 10:56 AM
Rough idle... Dies at idle... No power Chevrolet.Love Engine & Transmission 0 08-19-2011 10:05 PM
Rough Running, Rough Idle, Idles Hot nhguy261 Engine & Transmission 17 12-30-2010 02:41 PM
rough idle & poor gas mileage again CrazyJ 2nd Gen S-series (1995-2005) Tech 2 04-21-2007 12:01 PM

Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 03:33 PM.

Internet Brands, Inc.