wet distributor - Blazer Forum - Chevy Blazer Forums

Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech

Closed Thread
LinkBack Thread Tools Search this Thread
Old 12-01-2010, 09:40 PM
New Member
Join Date: Dec 2010
Posts: 2
96loaded is on a distinguished road
Default wet distributor

i cleaned the block and think i may have gotten the distributor a little wet..the motor would tunr over but would not fire..after lettin it sit for about an hour i tried it again and it started but ran rough..the longer it ran the better it started to run, but now when i start it, it idles at around 1500-2500 rpm..any ideas or help would greatly be appreciated..also wheni apply the brakes the engine still wants to remain at 1500-2000 rpm, which means im fighting to slow the truck down..if it helps it a 96 4.3 4x4 4 door lt or le, whichever was the top of the line for that year..thanks again...
Closed Thread

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wet Carpet in the back....pls help. PhillyZ 2nd Gen S-series (1995-2005) Tech 5 10-06-2009 02:10 AM
wet under rug agent305 2nd Gen S-series (1995-2005) Tech 3 10-08-2007 12:26 PM
Passenger side floor wet bigbill23 2nd Gen S-series (1995-2005) Tech 8 05-29-2007 01:25 AM
figure this wet one out... Paddle_grl 2nd Gen S-series (1995-2005) Tech 14 03-21-2007 01:17 AM
WET WEATHER HESITATION MRDCSE 2nd Gen S-series (1995-2005) Tech 4 11-30-2006 12:21 AM

96, blazer, chevy, damp, distribuitor, distributor, distrubutor, fire, lt, rough, runs, start, wet

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -5. The time now is 07:31 AM.