Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-14-2009, 08:30 PM
New Member
 
Join Date: Jan 2009
Posts: 4
ffalan is an unknown quantity at this point
Default Will not shift into park

My 98 S-10 Blazer will not shift into park. There doesn't seem to be a visible problem with the gear selector on the column. There is no slipping in any of the gears, it just will not move completely into the Park position. The Park "light will not light up on the dash and the car will roll if left on an incline. Also, as you might have guessed, it will only crank in neutral.

Ideas?

Alan L
Reply With Quote
  #2  
Old 10-14-2009, 08:34 PM
swartlkk's Avatar
Administrator
2009 GMC Yukon Denali
My Garage
 
Join Date: May 2005
Location: Waterloo, NY
Posts: 36,946
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Send a message via ICQ to swartlkk Send a message via AIM to swartlkk
Default

Shift linkage out of adjustment? Check out THIS POST for details on how to adjust the shift linkage.
Reply With Quote
  #3  
Old 10-14-2009, 09:42 PM
Banned
 
Join Date: Oct 2009
Posts: 127
blazerboyz is on a distinguished road
Default

take a look under the truck on the driver side of the trans and see how the shift linkage is see if it came loose, you can tell by just putting your hand on it and give it a good wiggle, if not?! You and a buddy will be at this for a wile one in the truck the other underneith and you will have to adjust to what the underneith guy says, any who you will figure it out its not a big deal
Reply With Quote
  #4  
Old 07-30-2010, 11:58 AM
Starting Member
 
Join Date: Jul 2010
Location: Schuylkill County, PA
Posts: 1
DeWalt is on a distinguished road
Default

Quote:
Originally Posted by ffalan View Post
My 98 S-10 Blazer will not shift into park. There doesn't seem to be a visible problem with the gear selector on the column. There is no slipping in any of the gears, it just will not move completely into the Park position. The Park "light will not light up on the dash and the car will roll if left on an incline. Also, as you might have guessed, it will only crank in neutral.

Ideas?

Alan L
Have the same problem with my '96. Followed the suggested steps to adjust the shifter linkage that was provided. It worked 3 instances of putting it into park but has since returned to not going into park again.
Reply With Quote
  #5  
Old 08-01-2010, 10:49 AM
Senior Member
 
Join Date: Oct 2008
Location: Tucson, Arizona
Posts: 764
LannyL81 is an unknown quantity at this point
Default

Question: using your hand are you able to shift the trans into park by pushing on the linkage at the trans? If so then it is the cable. It is out of adjustment because it has probably broken. This is a PITA to fix as the new cable runs under the carpet and through a grommet in the floor. Actually takes about two hours to replace...but what a PITA to do.

What happens is the clip that holds the adjustment is in a plastic body. The plastic body has broken so the entire cable moves instead of pushing or pulling the shift linkage.

Did I mention that this is a PITA to replace....

Mine broke one night for the wife...and after two weeks of putting trans in neutral, setting parking brake, crawling under to push linkeage into park...I had enough and replaced the cable.

Got mine from Rock Auto.

Good luck and oh....have fun.
__________________
LannyL81
2002 4dr 4wd S10 Blazer
Reply With Quote
Old 08-01-2010, 10:49 AM
 
 
 
Reply

Tags
1991, 1995, 2000, adjust, blazer, chevy, gear, linkage, park, s10, shift, shifter, trans, truck, wont


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 11:29 PM.

Internet Brands, Inc.