Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > Engine & Transmission
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-23-2012, 01:10 AM
Beginning Member
1995 GMC Jimmy
 
Join Date: May 2012
Posts: 23
stephen5217 is an unknown quantity at this point
Exclamation 1995 4.3l V6 Vortec SPUTTERING/MISFIRE on acceleration

About a week ago I was driving my car when it suddenly started sputtering and driving almost like it was out of gas this stopped and I left it alone. The next day the same thing happened, and to overcome the sputtering I accelerated faster and it was no longer noticeable. (This is mainly happening once the engine heats up) Now it is terrible, I cant drive a half mile without it bucking with acceleration and dying at a low idle while in drive at a stop sign. I have been driving it to test things that I have fixed which have not fixed the problem yet.

I have replaced these things:
Spark Plugs, Spark Plug Wires, Distributor Cap, Distributor Rotor, Throttle Position Sensor, MAP Sensor and the Fuel Filter. I have cleaned/checked the EGR valve, Idle air valve, vacuum lines electrical connections, fluids, and inside the intake plenum where it seems clean (no broken/leaking lines).

I feel like I have done everything possible, but I know there are a couple more sensors I could change, and possibly change the fuel injector/pressure regulator.

Whats next? Has anybody had something similar happen?

Thanks
Reply With Quote
  #2  
Old 05-23-2012, 01:18 AM
chris015's Avatar
BF Veteran
1993 Chevrolet S10 Blazer
 
Join Date: Apr 2009
Location: South Carolina
Posts: 3,639
chris015 has a spectacular aura aboutchris015 has a spectacular aura aboutchris015 has a spectacular aura about
YOUMADBRAHLOL
Default

before you do ANYTHING else check fuel pressure. it must be above 59ish at key on and hold above 55 for 10 min. if its low replace pump,if its good then slowly drops its probably the spider.

If you replace the pump,ONLY buy ac delco. these blazers are so picky on pumps. dont chance it like me,and 40000000 others did. We ended up doing it again.
__________________
Like a boss.
Reply With Quote
  #3  
Old 05-23-2012, 01:30 AM
Super Member
1999 GMC Jimmy
 
Join Date: Mar 2012
Location: Iowa
Posts: 1,024
50lb_cat will become famous soon enough
Default

Actually if inside the plenum is clean it means something is leaking. Either the fuel pressure reg is leaking or the injectors are leaking. Its normal for the plenum to be black and sooty looking.
Reply With Quote
  #4  
Old 05-23-2012, 01:42 AM
Beginning Member
1995 GMC Jimmy
 
Join Date: May 2012
Posts: 23
stephen5217 is an unknown quantity at this point
Default

Sorry, I should have specified more. It is clean as in there is no pooling of fuel, and it is not abnormally filthy or clogged up. I cleaned it several months ago too and put a new gasket on.
Reply With Quote
  #5  
Old 05-23-2012, 11:46 AM
Banned
 
Join Date: May 2012
Posts: 5
bagged02 is on a distinguished road
Default

I am new to the site AND SIGNED UP BECAUSE im having this SAME issue.
Reply With Quote
  #6  
Old 05-23-2012, 11:51 AM
chris015's Avatar
BF Veteran
1993 Chevrolet S10 Blazer
 
Join Date: Apr 2009
Location: South Carolina
Posts: 3,639
chris015 has a spectacular aura aboutchris015 has a spectacular aura aboutchris015 has a spectacular aura about
YOUMADBRAHLOL
Default

for the both of you. A bad area in these are the fuel systems aka pump and spider injection. Whenever they start to go out,you will get all kinds of hard starts,flooding,rough idles,sputtering etc. A simple pressure test will tell you if you have a fuel issue. You can go to autozone and borrow a pressure tester for free,but you have to leave a deposit in case you dont return it. You get every penny back when you take it back.
__________________
Like a boss.
Reply With Quote
  #7  
Old 05-23-2012, 11:56 AM
Starting Member
 
Join Date: Mar 2012
Posts: 178
chevyracingfan23 is on a distinguished road
Default

Quote:
Originally Posted by chris015 View Post
for the both of you. A bad area in these are the fuel systems aka pump and spider injection. Whenever they start to go out,you will get all kinds of hard starts,flooding,rough idles,sputtering etc. A simple pressure test will tell you if you have a fuel issue. You can go to autozone and borrow a pressure tester for free,but you have to leave a deposit in case you dont return it. You get every penny back when you take it back.
How much they charge you for deposit? I am working part-time so I don't make much.
Reply With Quote
  #8  
Old 05-23-2012, 02:00 PM
Beginning Member
1995 GMC Jimmy
 
Join Date: May 2012
Posts: 23
stephen5217 is an unknown quantity at this point
Default Fuel Pressure Tester

I'll be doing that today. I'm guessing autozone will charge $50 for the tester... thats how much one costs new and thats how they price.
Reply With Quote
  #9  
Old 05-23-2012, 02:43 PM
chris015's Avatar
BF Veteran
1993 Chevrolet S10 Blazer
 
Join Date: Apr 2009
Location: South Carolina
Posts: 3,639
chris015 has a spectacular aura aboutchris015 has a spectacular aura aboutchris015 has a spectacular aura about
YOUMADBRAHLOL
Default

I THINK it was like 100 bucks. I dont remember. They usually charge more since the parts are usually a higher commercial quality since they are being loaned out. call and ask..
__________________
Like a boss.
Reply With Quote
  #10  
Old 05-24-2012, 12:31 AM
Beginning Member
1995 GMC Jimmy
 
Join Date: May 2012
Posts: 23
stephen5217 is an unknown quantity at this point
Default

Alright, today I got the fuel pressure testing gauge. I followed all of the directions that were included and got the running test, acceleration test, and battery (system priming pressure) test. The pressure range that my Jimmy is supposed to stay at is 56-66... That seems like a large range.

So I turned the ignition on, but not the engine and the fuel pressure jumped up to 64, but then instantly dropped. It took it about a minute to reach 20. After that I turned the ignition on and off to pressurize it more and it did the same thing... it just couldnt hold pressure.

I then turned the engine on and the pressure jumped up to 56/57 and stayed steady for the most part. If I pulled on the throttle it would jump up about 1 and as soon as I let off it would drop down to 52/54. I tried the same in neutral and it was just a bit more extreme, but not too much different. (The car sputters while in neutral, but not park)

So what it seems to me is that my fuel pressure is low, and it does not hold pressure while the engine is off (which it is supposed to I guess). So what now, can anybody think of any other ways to test it, or different things I could try before I return the pressure tester?

Thanks... let me know
Reply With Quote
Old 05-24-2012, 12:31 AM
 
 
 
Reply

Tags
1991, 1995, 43, 43l, accelerating, acceleration, blazer, chevy, gmc, idle, jimmy, misfire, sputters, v6, vortec


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 GMC Jimmy - Sputter/Misfire under acceleration extreme17 2nd Gen S-series (1995-2005) Tech 10 09-26-2014 09:20 PM
Sputtering on acceleration.....have codes!! JetJock79 Engine & Transmission 9 03-07-2011 10:32 AM
Sputtering during acceleration bigsmitty Engine & Transmission 2 10-26-2009 08:45 PM
1995 vortec v 1996+ vortec mrblonde108 General Chat 14 10-04-2009 02:08 PM
1995 Blazer Stumbling idle and under acceleration Blazer4U 2nd Gen S-series (1995-2005) Tech 3 08-18-2008 07:23 PM

Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 04:23 AM.

Internet Brands, Inc.