2000 blazer acceleration sluggish problems - Page 2 - Blazer Forum - Chevy Blazer Forums


Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > Engine & Transmission
Sign in using an external account
Register Forgot Password?
Search



Closed Thread
 
 
 
 
LinkBack Thread Tools Search this Thread
  #11  
Old 06-15-2011, 01:17 AM
Beginning Member
 
Join Date: Jun 2011
Posts: 10
HateToLoveIt is on a distinguished road
Default Hey good man Im new...

I had just bought mine recently and after doing a little research on her I found out that the vortec is a 200 horsepower engine which you got to admit aint bad but mine was running sluggish also. I wasnt throwing no codes just didnt have the get up and go it should have expecially going up hill. Had a good friend tell me that these beasts are prone to having clogged catylitic converters, went ahead and bought one new and you wouldnt balieve the difference, like night and day. I dont understand how it would have a huge impact on the engine but its doing alot better now. Worth a try to give it a check...
Old 06-15-2011, 01:17 AM
 
 
 
Closed Thread

Tags
2000, accelerate, accelerating, acceleration, aceleration, blazer, change, chevrolet, chevy, lt, problem, problems, shift, sluggish, weak


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


 
Advertising
Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 07:10 PM.

Internet Brands, Inc.