2005 Trailblazer evap problems - Blazer Forum - Chevy Blazer Forums

Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > Engine & Transmission

Closed Thread
LinkBack Thread Tools Search this Thread
Old 03-12-2011, 05:42 PM
Starting Member
Join Date: Mar 2011
Posts: 1
joanayres is on a distinguished road
Default 2005 Trailblazer evap problems

My 05 Blazer had the codes Po410 and Po455, our mechanic hooked the smoke machine up to it. It showed the vent solenoid was leaking, so he replaced the part, and cleared the service engine light. I hadn't drove it 20 miles, and the SEL came on again. So, evidently, that didn't fix it. Wondering if the mechanic didn't let the smoke machine go full circle. What else could it be? What do i need to do? HELP! (The little icon fits my mood!)
Closed Thread

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sunroof Problems 2005 Trailblazer LT jmberman 2nd Gen S-series (1995-2005) Tech 1 09-24-2014 04:53 PM
2005 blazer 2 door / CODE P0449 / 4.3 L VORTEC / evap canister vent solenoid location joejiz 2nd Gen S-series (1995-2005) Tech 18 11-14-2012 04:31 PM
2005 TrailBlazer rear power outlets not working trailblazer333 GMT 360/370 Tech 1 06-24-2007 10:41 AM
2005 trailblazer fuel filter location jerryh20 GMT 360/370 Tech 10 06-04-2007 05:06 PM
whining noise in 2005 trailblazer smh7890 General Tech Help 4 07-28-2006 09:46 PM

2005, blazer, chervolet, chevy, code, evab, evap, evop, location, po455, problem, problems, sensor, solenoid, trailblazer

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -5. The time now is 05:13 AM.