Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


 
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-14-2006, 04:46 PM
 
Join Date: Nov 2005
Posts: 34
dashyman is an unknown quantity at this point
Default Trouble Code P1406??

The check engine light came on in my 95 Blazer 4.3, this has happend on occasion. I went to Autozone (I know, don't yell at me) and they ran the trouble codes and came up with a code number P1406 - they called it a dealer code, it is not in the Haynes book.

They told me it was associated with the "air Pump"?? and that it was a "dealer code".

They also said that 95 blazers did not have the port to connect the analyzer to and that I must have a 1996 engine in my 95 Blazer (this is autozone - so i took it with a grain of salt).

Can any one shed some light on either the trouble code and what I need to do to fix it?

They reset the codes, but it came back on - in the past after a while the car would start to run rich and I would reset the codes and all woud be OK for a couple 1000 miles.

Thanks for the help
  #2  
Old 08-14-2006, 05:07 PM
Administrator
 
Join Date: Nov 2005
Location: Zanesville oHIo
Posts: 2,930
hillbillyinOhio has disabled reputation
Send a message via AIM to hillbillyinOhio Send a message via Yahoo to hillbillyinOhio
Default RE: Trouble Code P1406??

The P1046 is an egr code, probably due to carbon buildup, try removing the egr and cleaning it out, should help. there are many threads on the site about egr issues.

here is a post by Kyle, hope I'm doin this right!!

Quote:
ORIGINAL: swartlkk

If, when you remove the EGR valve, you see a scaled buildup on the inside of the EGR feed (from the exhaust manifolds - IIRC, this is the bottom hole), then you'll need to clean it out. I have done this with a steel pipe cleaner (3/4" diameter) and some carbon cleaner. Spray the carbon cleaner up the tube and stop it up so it can't come back out. Wait a bit, then spray some more up in there and work at it with the pipe cleaner. I grabbed my pipe cleaner from the maintenance dept at work, but I think someone else came up with anothe source in another thread.

Once you're all said and done, Leave the EGR valve off and start the vehicle only for a quick instant. It will blow any crap that you broke loose out. I believe it was blazingsadle who first recommended starting it with the EGR valve off and it works great to clean out the supply tube. Just don't be standing in front of the truck when you do it and have it pointed in a safe, clear, and hopefully not clean area because it'll spray carbon and crap for quite a ways.

Good luck.
__________________

MECP Master Installer
2007 Chevy Silverado Ext cab Stock
2008 Jeep Commander - Stock
2000 Jeep Wrangler - 4" Lift 33's
1978 Jeep J-10 4" Lift, 33's (soon to have SOA and 37's)
  #3  
Old 08-14-2006, 05:07 PM
Beginning Member
 
Join Date: Jul 2006
Location:
Posts: 26
moggy59 is an unknown quantity at this point
Default RE: Trouble Code P1406??

That's weird, in my Haynes it says P1406 is "EGR Position Sensor Performance".

This post talks to that problem/code:

http://www.blazerforum.com/m_20451/tm.htm

Hope it helps.

__________________
1996 LT 4WD S10 Blazer 4.3L
  #4  
Old 08-14-2006, 05:16 PM
swartlkk's Avatar
Administrator
2009 GMC Yukon Denali
My Garage
 
Join Date: May 2005
Location: Waterloo, NY
Posts: 36,949
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Send a message via ICQ to swartlkk Send a message via AIM to swartlkk
Default RE: Trouble Code P1406??

I ran into this recently with someone on a newer than '95 vehicle. For them, P1406 was an EGR performance fault. It is an EGR fault of some sort even for your '95. Do you have the CPI motor (tb pointing forward) or the SCFI motor (tb pointing up)?

The problem is that in '95, the PCMs were OBD1.5 (not OBD1 and not quite OBD2). Also, '95 was a transitional year between the older CPI motors and the newer SCFI motors.
  #5  
Old 08-14-2006, 05:19 PM
 
Join Date: Nov 2005
Posts: 34
dashyman is an unknown quantity at this point
Default RE: Trouble Code P1406??

The motor is the CPI, with the throttle opening pointing forward
  #6  
Old 08-14-2006, 05:23 PM
swartlkk's Avatar
Administrator
2009 GMC Yukon Denali
My Garage
 
Join Date: May 2005
Location: Waterloo, NY
Posts: 36,949
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Send a message via ICQ to swartlkk Send a message via AIM to swartlkk
Default RE: Trouble Code P1406??

I'm going to let someone that knows more about the EGR valve on the CPI motors fill in the blanks. I think it is a bit different from the SCFI EGR location.
  #7  
Old 08-14-2006, 05:30 PM
Administrator
 
Join Date: Nov 2005
Location: Zanesville oHIo
Posts: 2,930
hillbillyinOhio has disabled reputation
Send a message via AIM to hillbillyinOhio Send a message via Yahoo to hillbillyinOhio
Default RE: Trouble Code P1406??

I would look at if you are fouling spark plugs.
__________________

MECP Master Installer
2007 Chevy Silverado Ext cab Stock
2008 Jeep Commander - Stock
2000 Jeep Wrangler - 4" Lift 33's
1978 Jeep J-10 4" Lift, 33's (soon to have SOA and 37's)
Old 08-14-2006, 05:30 PM
 
 
 
 

Tags
1995, 43, blazer, check, chevrolet, chevy, code, codep1406, egr, engine, fault, gm, light, p1046, p1406, trouble


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 11:36 AM.

Internet Brands, Inc.