Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > Lighting & Electrical
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-15-2012, 08:27 PM
97cherryblazer's Avatar
Super Member
1997 Chevrolet Blazer
 
Join Date: Sep 2010
Location: Lynnwood WA
Posts: 1,485
97cherryblazer will become famous soon enough97cherryblazer will become famous soon enough
Default HID low beam problem

Well new problem.. During the wheeling trip i was just on for the last 4 days my low beams quit working. It happened when i was driving down a bumpy trail, they started flickering then quit working, and when they did the DRL symbol came on in my dash. and when i turn them off and turn them on my RPM's will drop by about 200 and the DRL light symbol will come on and sometimes if i hit a bump the lights will flicker but never stay on. But the High beams work just fine.

So i dont really know where to start, i know the ballasts go into safe mode but i thought they were supposed to come back on when you turn the key off then back on. I suppose they could be bad, but would both of them go bad at once? my other guess is loose wire, but i dont know where the head light ground and power wires run to.

So if anyone can help that would be greatly appreciated.
__________________
97 Blazer 4x4 4Dr
2" Body Lift, 31" DuraTracs, Steel Bumper, Spare Tire Carrier
Reply With Quote
  #2  
Old 09-16-2012, 03:35 AM
Thogert's Avatar
Moderator
2007 Chevrolet Cobalt
My Garage
 
Join Date: Nov 2010
Location: Northern Utah
Posts: 4,080
Thogert has a spectacular aura aboutThogert has a spectacular aura aboutThogert has a spectacular aura about
Thor Rankin @thogert Thogert
Default

Are you using a relay harness?
__________________

Need to know what to buy to get an Led interior? Click here.
For years 95-05.
Projects: Tigger: Sold. Jenna: Hibernation time. Sasha: Nothing much.
Reply With Quote
  #3  
Old 09-16-2012, 10:56 AM
Rottidog's Avatar
BF Veteran
2002 Chevrolet Blazer
 
Join Date: Sep 2008
Location: Winnipeg, Manitoba
Posts: 2,514
Rottidog has a spectacular aura aboutRottidog has a spectacular aura about
Send a message via MSN to Rottidog Send a message via Yahoo to Rottidog
Default

Sounds like you have something grounding out that shouldn't be.
I suppose you've checked all the connections & wiring but what about inside the ballasts? Is it possible yo look inside them? Because it sounds like the board could be grounding out to the metal box of the ballast or wires inside.
__________________
'02 Blazer 2dr. 4x4
Supercharged, Marine Intake & Bosch Injected
Cammed
Lifted
Modified
Wolf Performance dynotuned PCM www.wolfperformance.com/about.html#Title1 <-- look at that resume & tell me you'd be uncomfortable with him working on your vehicle.
www.photobucket.com/albums/dd486/Rottidog/CB%20The%20Cranberry%20Blazer%20_GF%20made%20up%20 the%20name_/
YouTube http://www.youtube.com/watch?v=Bl0YwGxOJms&feature=plcp
Reply With Quote
  #4  
Old 09-16-2012, 01:54 PM
97cherryblazer's Avatar
Super Member
1997 Chevrolet Blazer
 
Join Date: Sep 2010
Location: Lynnwood WA
Posts: 1,485
97cherryblazer will become famous soon enough97cherryblazer will become famous soon enough
Default

I havent checked the wires going to the power block because i couldnt find it lol but then i remembered the quad beam mod thread that told me where its at so im going to look at them today.

I tried switching the high and low beam ballasts on one side and it still didnt work so that kinda tells me its further back either in the switch or the remote wire (im guessing thats what its called?) while im in there i might as well do the quad beam mod.

but yesterday when i was trying to figure it out the DRL symbol kept flickering and the relay clicking in the glove box while the truck was parked so bouncing didnt have anything to do with it.
__________________
97 Blazer 4x4 4Dr
2" Body Lift, 31" DuraTracs, Steel Bumper, Spare Tire Carrier
Reply With Quote
  #5  
Old 09-16-2012, 02:08 PM
Rottidog's Avatar
BF Veteran
2002 Chevrolet Blazer
 
Join Date: Sep 2008
Location: Winnipeg, Manitoba
Posts: 2,514
Rottidog has a spectacular aura aboutRottidog has a spectacular aura about
Send a message via MSN to Rottidog Send a message via Yahoo to Rottidog
Default

Maybe not bouncing but vibrations on a loose connecion will cause flickering.
Maybe the ground under the fuse box under the hood or body ground?
But for it to cause other issues like RPM's etc I still think something is grounding out that shouldn't be.
Check around the coil & other wiring harneses.
__________________
'02 Blazer 2dr. 4x4
Supercharged, Marine Intake & Bosch Injected
Cammed
Lifted
Modified
Wolf Performance dynotuned PCM www.wolfperformance.com/about.html#Title1 <-- look at that resume & tell me you'd be uncomfortable with him working on your vehicle.
www.photobucket.com/albums/dd486/Rottidog/CB%20The%20Cranberry%20Blazer%20_GF%20made%20up%20 the%20name_/
YouTube http://www.youtube.com/watch?v=Bl0YwGxOJms&feature=plcp
Reply With Quote
  #6  
Old 09-16-2012, 06:09 PM
97cherryblazer's Avatar
Super Member
1997 Chevrolet Blazer
 
Join Date: Sep 2010
Location: Lynnwood WA
Posts: 1,485
97cherryblazer will become famous soon enough97cherryblazer will become famous soon enough
Default

Well i did some looking around and didnt find anything, i unplugged the big wire connector for the high and low beams (and other things) and checked the connections and they were all fine. And looked everywhere for grounds/bare wires and didnt find any. well i did find 3 wires that dont go to anything but look like they havent been plugged into anything ever so dont think thats a problem.

But then i remembered my passenger side corner light went out at the same time everything else did. when i turn the lights on the driver side corner light repeatedly dims with the drop in RPM's and the two bumper turn signals are on. So could this corner light be causing the problems?? I dont see how it would unless one of its wires are shorting things out.
__________________
97 Blazer 4x4 4Dr
2" Body Lift, 31" DuraTracs, Steel Bumper, Spare Tire Carrier

Last edited by 97cherryblazer; 09-16-2012 at 06:19 PM.
Reply With Quote
  #7  
Old 09-18-2012, 09:16 PM
97cherryblazer's Avatar
Super Member
1997 Chevrolet Blazer
 
Join Date: Sep 2010
Location: Lynnwood WA
Posts: 1,485
97cherryblazer will become famous soon enough97cherryblazer will become famous soon enough
Default

Well Rotti you were right... lol should have listened to you about the ballasts. I only switched the passenger side ballast, then i looked in my book and saw how the circuit works and realized if the driver side ballast is out both lights wont work and then i realized that the driver side ballast was getting hot so i switched it with the high beam ballast and all is well now.

Good thing they are under a 1 year warranty still
__________________
97 Blazer 4x4 4Dr
2" Body Lift, 31" DuraTracs, Steel Bumper, Spare Tire Carrier
Reply With Quote
  #8  
Old 09-18-2012, 10:06 PM
Rottidog's Avatar
BF Veteran
2002 Chevrolet Blazer
 
Join Date: Sep 2008
Location: Winnipeg, Manitoba
Posts: 2,514
Rottidog has a spectacular aura aboutRottidog has a spectacular aura about
Send a message via MSN to Rottidog Send a message via Yahoo to Rottidog
Default

TY TY. I remember reading that Kyle (swartlkk) had said the 2nd gen headlight wiring is very odd. Did it also cure the marker light issue?
__________________
'02 Blazer 2dr. 4x4
Supercharged, Marine Intake & Bosch Injected
Cammed
Lifted
Modified
Wolf Performance dynotuned PCM www.wolfperformance.com/about.html#Title1 <-- look at that resume & tell me you'd be uncomfortable with him working on your vehicle.
www.photobucket.com/albums/dd486/Rottidog/CB%20The%20Cranberry%20Blazer%20_GF%20made%20up%20 the%20name_/
YouTube http://www.youtube.com/watch?v=Bl0YwGxOJms&feature=plcp
Reply With Quote
  #9  
Old 09-18-2012, 10:32 PM
97cherryblazer's Avatar
Super Member
1997 Chevrolet Blazer
 
Join Date: Sep 2010
Location: Lynnwood WA
Posts: 1,485
97cherryblazer will become famous soon enough97cherryblazer will become famous soon enough
Default

Nah that light was completely burnt lol so i changed it. But yeah the wiring on it is definitely strange.. Parently that short caused the DRL's to think they needed to be on..? idk its strange.
__________________
97 Blazer 4x4 4Dr
2" Body Lift, 31" DuraTracs, Steel Bumper, Spare Tire Carrier
Reply With Quote
  #10  
Old 09-18-2012, 10:37 PM
Rottidog's Avatar
BF Veteran
2002 Chevrolet Blazer
 
Join Date: Sep 2008
Location: Winnipeg, Manitoba
Posts: 2,514
Rottidog has a spectacular aura aboutRottidog has a spectacular aura about
Send a message via MSN to Rottidog Send a message via Yahoo to Rottidog
Default

Hmmm... maybe the grounding out in the ballast was causing a feedback or loop to the DRL's?
__________________
'02 Blazer 2dr. 4x4
Supercharged, Marine Intake & Bosch Injected
Cammed
Lifted
Modified
Wolf Performance dynotuned PCM www.wolfperformance.com/about.html#Title1 <-- look at that resume & tell me you'd be uncomfortable with him working on your vehicle.
www.photobucket.com/albums/dd486/Rottidog/CB%20The%20Cranberry%20Blazer%20_GF%20made%20up%20 the%20name_/
YouTube http://www.youtube.com/watch?v=Bl0YwGxOJms&feature=plcp
Reply With Quote
Old 09-18-2012, 10:37 PM
 
 
 
Reply

Tags
05, ballast, beam, beams, blazer, chevy, dim, dont, flicker, headlight, hid, hids, high, lit, low, mustang, put, symbol, time, wont


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Headlights low beam problem dkatz Lighting & Electrical 7 03-02-2011 07:44 AM
Hi / Lo Beam HID conversion reporob 2nd Gen S-series (1995-2005) Tech 2 06-03-2010 03:48 PM
Headlights flicker from low beam to high beam? marine 2nd Gen S-series (1995-2005) Tech 1 01-28-2010 08:05 PM
High beam/low beam question dimmuborgir6nik6 Audio/Video Electronics 2 02-27-2008 02:34 PM
Low beam headlights AzBlazer 2nd Gen S-series (1995-2005) Tech 1 07-03-2005 05:17 PM

Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 12:11 AM.

Internet Brands, Inc.