View Full Version : 1st Gen S-series (1983-1994) Tech


Pages : 1 2 3 4 5 6 7 8 9 10 11 12 13 [14] 15 16 17 18 19

  1. starts but dies when gas is applied.
  2. A couple questions about replacing brakes
  3. ABS - Should I bother?
  4. 1994 S10 Blazer wont start after driven for a while
  5. swaping a mtr.
  6. Temperature Switch
  7. Issues Acceleratiing when Cold.
  8. Blazer or Jimmy Shopping
  9. Window motors
  10. interchange?
  11. remote keyless door lock
  12. 1991 4.3 Changes??
  13. Looks like I got to replace my front brake lines
  14. Blowing radio fuse after startup
  15. Need Verification on RPO Code
  16. Fuel system issue ???
  17. Very Odd Situation
  18. 88 2.8v6 wont idle with both injectors hooked up and no power...wtf?
  19. wanting to rebuild my engine got a question
  20. Digital Cluster Issue As Well??
  21. Auto Door Lock Question
  22. RPO Codes
  23. Starting engine drains battery
  24. Need o2 Sensor Part Number
  25. exhaust leak
  26. '84 2.8, E2SE - Insane Overfueling, No-Start
  27. 1992 s10 blzr digital dash problems
  28. 87 blazer chugging prob
  29. 1992 s10 blazer fuel problems
  30. Tire and t-bars, upgrades
  31. question about front end of an S10 Blazer
  32. 1985 s10 blazer problems ;(
  33. God dang Blazer!!!!
  34. Engine Swap
  35. FAST IDLE
  36. Do i need valve seals or piston rings?
  37. 89 gmc no power
  38. Fuel line disconnecting
  39. reverse lights
  40. 93 blazer overheating 4.3L
  41. window motor
  42. awfull front end noise over bumps
  43. 4x4 question
  44. rough surging idle
  45. Suspension work, got some advice for me?
  46. How many O2 sensors do I have?
  47. Weird Instrument Panel
  48. 94 jimmy transmission
  49. Wierd short or battery drain
  50. DTC-35 CEL error, Idle Air Control ??
  51. ignition/gauges fuse problems..94
  52. 93 4-lo problems
  53. S10 blazer light problem
  54. 91 blazer stalls after long idle
  55. Gauges Not Working HELLPPPP
  56. HELP!!!
  57. engine id
  58. 93 4x4
  59. odometer/trip odometer stopped working
  60. rough Idle.
  61. digital cluster to analog cluster?????
  62. problems with the grid on the back hatch
  63. Hydrolock question
  64. Egr Valve and Fuel Lines
  65. My 94 won't go into 4WD
  66. 94 blazer that will not start
  67. 1988 blazer
  68. 94 blazer Fuel Pump Problems
  69. Battery drain... :(
  70. Seriously What Now
  71. Leaf Springs off an Xtreme?
  72. Anybody use Triple Gauge packages at Autozone?
  73. 94 S10 Runs for about 15min on road then dies???
  74. Vaccuum Lines on TC Switch
  75. seats
  76. Oil Gauge is bobbing and drops to 0% in idle
  77. engine stalls when on the gas after long idle
  78. 93 idle issues
  79. Low power output, black smoke
  80. Where is the fusebox located??
  81. Cold Weather Starting Problems
  82. 94 s10 blazer fuel tank sending unit harness code
  83. 1993 4.3L vortec vin"W" 4x4- Coolent Leak!
  84. 94 blazer hard starts runs rough
  85. 93 Blazer will not start!
  86. Is my 4x4 unit going out??
  87. Tailgates Universal?
  88. Rear Hatch Doesn't Lock
  89. Transfer Case grind noise
  90. Replacing Taillights
  91. No Start.. Stall.. Backfires Through Throttle Body..
  92. headlight wires
  93. Leaking antifreeze
  94. oil/exhaust smell when I turn the blower on
  95. Rear window button not working
  96. Defrost Problems
  97. What Oil Weight and Capacity to use for 3.4l?
  98. Dies in Reverse, hissing behind dash
  99. 4x4 unit acting wierd?!
  100. overheating issues UPDATED
  101. hatch only poping sometimes ?
  102. rear lights not working
  103. wrong seat belts
  104. Fuel pressure
  105. wet weather poor performance
  106. 90 S10 Blazer stalling help...
  107. 4WD Posi-Lock Link System
  108. Replacing Vacuum Lines
  109. tranny/transfer case compatibility
  110. 1993 running problems
  111. 1993 blazer problems
  112. 91 Blazer Exhaust rattle
  113. under dash vacuum lines
  114. 94 Blazer issues. Please help!
  115. transmission fluid pan pains
  116. Knocking Noise
  117. front brakes 91 blazer
  118. shift lever
  119. RKE location
  120. help
  121. Was wondering if my blazer had a special 4X4 system or something
  122. weird turn signal/brake issue
  123. whats this line
  124. no fire on 91 blazer
  125. blower motor problems
  126. caliper brake hardware kit?
  127. parts compatablity
  128. funky MIL
  129. 1989 Jimmy 4x4 Emergency Brake light Flashing?
  130. 91 s10 blazer just not running right
  131. occasional grinding when driveing in 4wd
  132. starting problem, possible injector
  133. Dome Lights Coming On
  134. it no go straight anymore!
  135. Please Help, Fuel Pump Problems? Very Odd...
  136. multiple little probs
  137. Turn single release
  138. Another 4x4 Problem Post
  139. Another stalling while driving and idling problem... '92 CPI
  140. 93' brakes
  141. surges at cold start up
  142. No temp reading on temp guage
  143. need help removing digital dash
  144. 4x4 shift problems...
  145. 85 carb and coil set up
  146. 1989 Blazer 4x4,Distributor problems.
  147. help me please
  148. 1985 blazer project
  149. Rear Defroster
  150. Electrical problem
  151. An easy question...I'd think.
  152. no 4hi or 4lo
  153. questions
  154. Olds Bravada Help Needed Please!
  155. Need to know transmission number
  156. Runs weird when cold and/or wet (especially with both..)
  157. Door lock relay
  158. Skid Plates for First Gen??
  159. Intake plenum gasket
  160. 93 s10 blazer project
  161. a little clarification
  162. 305 blazer
  163. 1992 4.3 CPI warm IDLE PROBLEM
  164. problem charging
  165. running rich
  166. Crazy vibrations under the car
  167. Temp Gauge Woes...
  168. Gas Fumes, Fuel Fumes... It smells.
  169. Fuel problems with 94 chevy
  170. Bleed master cylinder
  171. no spark no fuel
  172. Four Wheel Low?
  173. i have no clue
  174. need help. dual toggle switch ignition
  175. wiring up dual toggle ignition
  176. Quick 4x4 question.
  177. Fuel pump question???
  178. hey guys im new to the forum and i need your help
  179. 3.8l 2 replace blown 2.8l
  180. Wipers...
  181. Idle
  182. 1993 Chev Blazer Idle issue
  183. oil pressure sender or gauge?
  184. Heater blower motor
  185. remiving the fuel lines
  186. Nob Q ruff motor
  187. heater
  188. I give up.....
  189. Has anyone ever seen a fuel pump harness melt?
  190. idleing rough lack of power
  191. OMG that NO-SMOKE just killed my truck
  192. 4x4 problem...
  193. HELP! ECM change- is it under the glove box?
  194. Timing issue
  195. Stalls While Driving
  196. axle ratios - 1994 - S10 Blazer 4x4 4.3 litre
  197. yet another problem
  198. 1993 4.3 vortec Vin "W" question
  199. New To Fourm and Need Some Help Please
  200. What to do with a 92?
  201. Need some help
  202. Need help PLEASE
  203. fuel in cylinders
  204. replaceing lines to cpi spyder
  205. Check engine light not working
  206. could it be the distributor?
  207. Botched rear end replacement... Even more questions!
  208. 4x4 conversion?
  209. Here is something new '94 S-10 Blzr not coming out of 4WD???
  210. fire from exhaust/smells horrible/wont idle
  211. No Heat Need Help Tried Everything
  212. 93 4.3cpi 2wheel wont start
  213. oil leak
  214. 93 conversion
  215. 90 4.3 TBI s10 Very Rough Idle Stalling
  216. Kill Switch and Oil question!
  217. Interior light question
  218. ive had enough
  219. Rear end Replacement, and Gear Ratio Questions
  220. 93 4.3 Loping Idle, Stalls, am stumped.
  221. Missing while driving
  222. Freeze out plug??
  223. choke thermostat
  224. HELP 91 blazer ABS light on
  225. Front end/ 4x4 help
  226. 1993 4.3 CPI 2WD Bad Fuel Pump Relay Symptoms
  227. gas tank leaking
  228. heater control vaccuum switch
  229. Chugging/Missing
  230. getting in and out of 4 wheel drive
  231. Quick Question...
  232. Problems with 4 Wheel Drive
  233. battery ground
  234. aftermarket temp gauge
  235. where does this wire go?
  236. 1993 4.3 2WD Hard Cold Starting
  237. Still having problems....
  238. 86 blazer info?
  239. Qucik Question need to know before tomm.
  240. wire diagram
  241. wires AGAIN
  242. Bad vibration/shaking
  243. FUSE PANEL HELP PLEASE
  244. Resurrecting my 86 S10 Blazer.....
  245. Another EGR POST
  246. pics please
  247. If The Gas Cap is Off Will it Run Rich?
  248. Not a smooth operator
  249. where's the oil filter
  250. How can I remove the TCCM and use my 233 in another vehicle?