Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > Steering, Suspension & Drivetrain
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Closed Thread
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-24-2009, 08:15 AM
 
Join Date: Dec 2009
Posts: 2
MissCee72 is on a distinguished road
Default 99 Jimmy 4x4 humming noise

99 Jimmy SLS 4x4 4.3 v6 vortec - 119k

I totally love this truck, why I don't know. All it does is drain my wallet.

I've replaced so much on this truck, it's pretty brand new in repairville. New: oil cooler lines, rear end, u joints, 4 axles, upper/lower ball joints, injectors, water pump, left & right front hubs, brakes, rotors, 4wd vacuum sensor, heater core, and the normal preventative maintenance as recommended.

Recently, it has been humming very loud from the front end. There is no change in the RPM's, no change in the way it feels on the road. The only change is the fact it hums, and seems to go: "woop woop" when I turn the corners from the engine. So, a week ago I the tension pulley replaced as it was shot. And I replaced the idler pulley and belt for good measure. The sound is still there. The crank pulley seems to be out of round, and kinda matches the "woop woop" sound I am hearing. Replacing these 3 things seemed to take the sound down some.

Another thing, my dash panel for the 4x4 went out a couple of months ago, and before it went out, my "service 4wd" light was coming on & going off intermittently. When I took it in to pull codes off, the light would go off when I turned off the truck, and would only come back on over 40 mph. Eventually the light just stopped coming on, and dash panel went out.

But, my main concern is this noise. Anyone have any ideas?
Old 12-24-2009, 08:15 AM
 
 
 
Closed Thread

Tags
4x4, 99, audio, blazer, change, chevy, end, front, hum, humming, joints, loud, noise, sound, universal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 11:17 PM.

Internet Brands, Inc.