1st Gen S-series (1983-1994) Tech Discuss 1st generation s-series (1983-1994) general tech topics here.

1994 s10 Blazer->Float fuel gauge and temp gauge not moving!

  #1  
Old 03-06-2008, 07:23 PM
Thread Starter
Join Date: Mar 2008
Posts: 4
Mulisha is an unknown quantity at this point
Default 1994 s10 Blazer->Float fuel gauge and temp gauge not moving!

I have a 1994 chevy s10 Blazer LT Tahoe and my analog fuel gauge floats horribly and my temperature gauge is not moving period and believe is setting off my check engine light every once in a while. Just bought the blazer and the fuel pump and gas tank have been changed by previous owner. Anything would help. Thanks
 
  #2  
Old 03-06-2008, 09:48 PM
Join Date: Aug 2007
Location: utah
Posts: 69
94blazer4.3ho is an unknown quantity at this point
Default RE: 1994 s10 Blazer->Float fuel gauge and temp gauge not moving!

Well for your fule gauge problem your out of luck, GM's fule sending unit are popular for having faults.Unless you replace the sending unitof course.For nowI have dicided to livewith the problem.As for the temperature gauge, you could replace the sending unit. Witch is fairly easy, and inexpencive. This sensor will set off the check engine light. Code 14 for high temp, or 15 for low. hope this helps.
 
  #3  
Old 03-06-2008, 10:39 PM
Join Date: Mar 2008
Posts: 10
eddiegreeny is an unknown quantity at this point
Default RE: 1994 s10 Blazer->Float fuel gauge and temp gauge not moving!

i changed my pump last year and my guage doest work. dont know if it is bad ground cuz i cut the wire, or what
 
  #4  
Old 03-07-2008, 03:19 PM
Thread Starter
Join Date: Mar 2008
Posts: 4
Mulisha is an unknown quantity at this point
Default RE: 1994 s10 Blazer->Float fuel gauge and temp gauge not moving!

I grinded down my ground location and it seemed to help a little but still floating. And where is the sending unit for me temp gauge.
 
  #5  
Old 03-13-2008, 12:29 AM
ATP
ATP is offline
Join Date: May 2007
Location: Lake Villa, IL
Posts: 49
ATP is an unknown quantity at this point
Default RE: 1994 s10 Blazer->Float fuel gauge and temp gauge not moving!

I have the same problem with my temp guage, it doesnt seem to move, and my fuel guage is kinda unreliable as well. Damn you GM.
 
  #6  
Old 03-24-2008, 09:14 PM
Thread Starter
Join Date: Mar 2008
Posts: 4
Mulisha is an unknown quantity at this point
Default RE: 1994 s10 Blazer->Float fuel gauge and temp gauge not moving!

I found out why the fuel guage is floating on the 1983-1994 s-10 blazers, By told through a GM dealer that year of vehicle does not have a "balast" or a little cup around the sending unit that has holes in the bottom of it for gas to enter. The balast is suppose to stop the wave of the gas in your tank from effecting your sending unit to keep your gauge steady. So there is one problem solved on to the next one.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
smtits
Engine & Transmission
8
07-05-2011 11:18 AM
zakm0n
Engine & Transmission
5
01-09-2011 07:31 PM
rogggg1020
Engine & Transmission
12
11-21-2008 07:00 AM
Danketch71
Engine & Transmission
3
03-13-2008 09:18 PM
ytsurkytsur
General Tech Help
2
06-23-2006 08:33 PM


Thread Tools
Search this Thread
Quick Reply: 1994 s10 Blazer->Float fuel gauge and temp gauge not moving!


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.