1st Gen S-series (1983-1994) Tech Discuss 1st generation s-series (1983-1994) general tech topics here.

backfiring

  #1  
Old 04-15-2012, 06:26 PM
Beginning Member
Thread Starter
Join Date: Dec 2009
Posts: 20
Gary99 is on a distinguished road
Default backfiring

Have a 99 Blazer V6 4x4 and now when I first pull out in the morning I am getting a popping backfiring noise thru the throttle body. The car feels like its being held back then I get this noise a few times. After that the car runs ok.
Any body have any ideas as to what this could be? I could really use the advise
Thanks
 
  #2  
Old 04-15-2012, 09:29 PM
Super Member
Join Date: Mar 2012
Location: Iowa
Posts: 1,024
50lb_cat will become famous soon enough
Default

Backfiring is usually a timing or ignition problem. You can also try disconnecting the maf sensor to see if it helps, if it does it needs cleaned. Have you done a tune up on it?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mbar
2nd Gen S-series (1995-2005) Tech
3
02-13-2010 09:36 AM
Iceman_19
2nd Gen S-series (1995-2005) Tech
2
08-26-2009 03:14 PM
chris12001
Full Size K5 (1969-1991) GMT415 (1992-1994) Tech
6
02-12-2009 11:44 PM
johncagain
Engine & Transmission
8
05-11-2008 08:30 PM
infamous
2nd Gen S-series (1995-2005) Tech
2
01-07-2007 04:18 AM


Thread Tools
Search this Thread
Quick Reply: backfiring


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.