Engine died while driving won't start No check engine light with key on - Blazer Forum - Chevy Blazer Forums

Go Back  Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 1st Gen S-series (1983-1994) Tech
Reload this Page >

Engine died while driving won't start No check engine light with key on

1st Gen S-series (1983-1994) Tech Discuss 1st generation s-series (1983-1994) general tech topics here.

Engine died while driving won't start No check engine light with key on

Reply

 
 
 
  #1  
Old 07-31-2012, 12:33 AM
Starting Member
Thread Starter
Join Date: Jul 2012
Posts: 4
doccheese is on a distinguished road
Default Engine died while driving won't start No check engine light with key on

1988 S10 blazer 2.8 4x4 manual trans
Help!
I was driving tonight everything dandy, good oil pressure and temp good. Then engine just quit, like someone had just unplugged it. No stammering or stuttering just flat quit. Coasted to a pull out on the road and tried to restart it, turned over fine but nothing. Turned key to the run position and the service engine light was not on as it should be. Would a failed ignition module cause these issues?
Thanks in advance for any help out here.
 
Reply With Quote
  #2  
Old 07-31-2012, 10:56 AM
Starting Member
Thread Starter
Join Date: Jul 2012
Posts: 4
doccheese is on a distinguished road
Default

I am going to have the ignition module checked this morning and will post results later.
 
Reply With Quote
  #3  
Old 07-31-2012, 01:07 PM
Starting Member
Thread Starter
Join Date: Jul 2012
Posts: 4
doccheese is on a distinguished road
Default fixed

Turned out to be scale build up on ecu fuse. Was not burned just scaled with corrosion just enough to kill the circuit. Go figure.
 
Reply With Quote
  #4  
Old 12-12-2014, 03:43 PM
Starting Member
Join Date: Dec 2014
Posts: 1
Nancy Pennington is on a distinguished road
Default

Im having same issue only sometimes it will start back but then just like i turned the engine off fuel pressure good changed fuel filter dist cap&rotor still cuts off&wont start back
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jeremy_in_Texas
Engine & Transmission
0
01-24-2015 06:58 PM
sunchiropractictables
2nd Gen S-series (1995-2005) Tech
10
01-02-2015 03:58 PM
zstudna
General Chat
4
10-15-2012 07:19 PM
2nd Gen S-series (1995-2005) Tech
9
08-18-2011 08:29 AM
sagoo33
2nd Gen S-series (1995-2005) Tech
3
07-29-2010 06:53 PM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory