1st Gen S-series (1983-1994) Tech Discuss 1st generation s-series (1983-1994) general tech topics here.

Hesitation, Idle, Power Issues

  #1  
Old 05-19-2019, 02:04 PM
Beginning Member
Thread Starter
Join Date: Dec 2017
Posts: 13
bhorn is on a distinguished road
Default Hesitation, Idle, Power Issues

Strange issue with my blazer. 89 4.3 4x4.

When starting cold, it rarely idles for more than 30-45 seconds before dying. I can give it the slightest amount of throttle for about 60 seconds or so to keep the revs up, and then let go and let it warm up.
When driving, if it isnít fully warmed up, the revs are very rough and it has little power. This usually only happens for about a block and then it starts running better but not perfectly. Even once fully warm, idle sometimes fluctuates slightly and power sometimes dips out (acts like it isnít getting gas)

Check engine light goes on and off. Sometimes it will stay on for 5-10 minutes, sometimes less than a minute. Occasionally it runs as if it had no issues and the check engine light is usually off during this. I have tried getting an engine code over 10 times now, and every time, no matter if the light is on or off before trying, as soon as I Bridge the obd connector to get into diagnostic mode, it always only gives me code 12 (which is no error just showing weíre in diagnostic mode). Itís frustrating cause I want to know what is causing the light when it does come on!

Anyone have experience with this? Thanks for reading,

Brad
 
  #2  
Old 05-19-2019, 04:49 PM
Beginning Member
Thread Starter
Join Date: Dec 2017
Posts: 13
bhorn is on a distinguished road
Default

I should also mention, I just cleaned the EGR valve, and did a seafood treatment. Poured some slowly into the tbi, let the brake booster vacuum line suck some up, and put a full 20oz can into 20 gallons of gas, and that really seemed to help. Maybe I should do more on the engine side?
i also just readiusted and double checked timing
 

Last edited by bhorn; 05-19-2019 at 05:03 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Matt 4.3 TBI
2nd Gen S-series (1995-2005) Tech
20
04-24-2017 11:22 PM
Chevrolet.Love
Engine & Transmission
0
08-19-2011 09:05 PM
mkrzy79
1st Gen S-series (1983-1994) Tech
5
05-10-2010 08:01 PM
LAWDOG
Engine & Transmission
1
03-05-2010 04:51 PM
MrRox
2nd Gen S-series (1995-2005) Tech
1
03-23-2009 10:19 AM


Thread Tools
Search this Thread
Quick Reply: Hesitation, Idle, Power Issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.