99 blazer - bad 4wd selector switch? - Blazer Forum - Chevy Blazer Forums


2nd Gen S-series (1995-2005) Tech Discuss 2nd generation s-series (1995-2005) general tech topics here.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 07-12-2013, 10:47 AM
Starting Member
Thread Starter
 
Join Date: Jul 2013
Posts: 2
Nayr is on a distinguished road
Default 99 blazer - bad 4wd selector switch?

Hello there, having some issues with the 4wd selector switch (4 button switch) in my 99 blazer.

Basically I don't get any lights when I have the engine is running, and nothing happens when I press the buttons. Is there a way to check the switch with a meter to determine if it's faulty?

I have checked the 4wd fuse in the fuse panel and it is good. Also, the "service 4wd" indicator is not on.

Any help is appreciated.
Reply With Quote
  #2  
Old 07-13-2013, 01:30 PM
Starting Member
Thread Starter
 
Join Date: Jul 2013
Posts: 2
Nayr is on a distinguished road
Default

Nobody?
Reply With Quote
  #3  
Old 07-28-2013, 04:29 PM
Beginning Member
 
Join Date: Apr 2010
Posts: 23
thered1 is on a distinguished road
Default

Happened to me when I first bought my 2000 with a 4 button. Replaced the switch, it's been happy ever since. I dont remember how much it was, but it wasnt horribly expensive.
Reply With Quote
  #4  
Old 07-28-2013, 04:30 PM
Beginning Member
 
Join Date: Apr 2010
Posts: 23
thered1 is on a distinguished road
Default

But someone else might have better advise on troubleshooting, etc. I just threw the dice and won on that one. Good luck!
Reply With Quote
  #5  
Old 08-02-2013, 08:44 PM
New Member
 
Join Date: Oct 2009
Posts: 6
nickzaw is on a distinguished road
Default

Having the same problem here but service 4WD light is still on after replacing the selector switch on the dash. I also switched the fuses and checked the vacuum actuator. Still no luck can anyone help?
Reply With Quote
  #6  
Old 08-03-2013, 02:57 AM
New Member
 
Join Date: May 2013
Location: S. E. Wisconsin
Posts: 2
Grandpa's old 2dr is on a distinguished road
Default Same problem

I'm having a Similair issue. Parked the truck at work one day, came out, gone in and fired her up and the service 4wd light came on and the push button selector had no orange selection light. Took out the battery to look under the battery tray and the actuator moves fine, no dry rot and the cable moves as it should, however when I replaced the battery and started it up the service 4wd light went off. Push button selector is still inoperable. Any ideas?
Reply With Quote
  #7  
Old 08-04-2013, 08:37 AM
Spree's Avatar
Starting Member
 
Join Date: Aug 2012
Posts: 118
Spree is on a distinguished road
Default

When my lights on the buttons quit working, I pulled the switch and noticed the switch came un-soldered from the circuit board. Re-soldered it back in and has been good for awhile now. Those switches can be fixed with a little patience, no need to buy a new one.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1995 4wd dash selector switch replacement? russosborne 2nd Gen S-series (1995-2005) Tech 7 05-30-2011 01:45 PM
Blower Motor Or Selector Switch? SWATPARAMEDIC Full Size K5 Tech 0 01-01-2010 03:12 PM
4x4 selector switch CodFos 2nd Gen S-series (1995-2005) Tech 1 04-19-2009 07:04 PM
4x4 selector switch blinking myblackblazer Steering, Suspension & Drivetrain 2 01-11-2009 11:15 AM
4x4 dead replaced selector switch Jetfixer 2nd Gen S-series (1995-2005) Tech 3 12-23-2005 01:54 PM


Tags
2000, 4wd, 4x4, 99, bad, blazer, lights, lt, motor, pushbutton, selector, shut, switch, trailblazer, troubleshoot, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:43 AM.