2nd Gen S-series (1995-2005) Tech Discuss 2nd generation s-series (1995-2005) general tech topics here.

A/C problem

  #1  
Old 07-10-2019, 08:37 AM
New Member
Thread Starter
Join Date: Nov 2017
Posts: 82
jimmy_for_ever is on a distinguished road
Question A/C problem

Hi

I have problem In my 00 jimmy. The a/c turn off on when I start it , continuously the compressor coil engaged then disengaged after 5 min of drive the compressor stop disengage and it work very good this mostly happen when I park car in the sun and ,when I touch the wire that goes to a/c compressor coil its become very hot.

((This Is the power wire that give to compressor coil I solder it in coil connector then I put the wire inside fuse box then I attached it by pushing the A/C FUSE inside because the original wire was cut from inside and it stop give power ))
 
  #2  
Old 07-10-2019, 10:59 AM
christine_208's Avatar
BF Veteran
Join Date: Dec 2016
Location: Moscow, ID
Posts: 2,088
christine_208 is on a distinguished road
Default

It could be a problem with the low pressure switch. (On my 1999 it is located on the large aluminum can called the accumulator.) It is part of the circuit that controls whether or not the clutch on the compressor is engaged or not. These can be replaced without venting the system. If your symptoms began somewhat suddenly and otherwise the system was working fine, I'd start with looking at or just simply replacing that switch as it is an easy and not very expensive fix to do at home.

However, if the switch has been working fine, then replacing that switch will not change anything and you could have a low pressure condition in the system which would most likely due to lack of refrigerant.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
hotrodsbyg
2nd Gen S-series (1995-2005) Tech
7
08-15-2011 11:47 AM
96realwe
Engine & Transmission
4
12-10-2010 09:19 AM
English5
2nd Gen S-series (1995-2005) Tech
0
07-16-2010 11:11 AM
Confuused69
2nd Gen S-series (1995-2005) Tech
12
08-02-2009 11:53 PM
Daytripper540
1st Gen S-series (1983-1994) Tech
2
03-29-2007 03:54 PM


Thread Tools
Search this Thread
Quick Reply: A/C problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.