2nd Gen S-series (1995-2005) Tech Discuss 2nd generation s-series (1995-2005) general tech topics here.

Rear Wiper Blade Problems

  #1  
Old 10-17-2007, 10:32 AM
Thread Starter
Join Date: Oct 2007
Posts: 4
zerokarma is an unknown quantity at this point
Default Rear Wiper Blade Problems

I recently bought a 1997 Chevy Blazer LT, everything on it is pretty much mint condition except the Wiper blade which doesn't seem to be working properly. It does move a little but usually gets stuck at some point on the window. If you help it a long a bit while its on it trys to go back and forth on the window but usually just stops or gets stuck at some point.

Is it likely the motor that is bad or something else?
 
  #2  
Old 10-17-2007, 10:55 AM
Junior Member
Join Date: Aug 2006
Location:
Posts: 395
BigGreenMonster is an unknown quantity at this point
Default RE: Rear Wiper Blade Problems

Is it likely the motor that is bad or something else?
Unless there is something you can see physically that is hanging the blade up while it is in motion, my money is on the motor.
 
  #3  
Old 10-17-2007, 11:54 AM
Starting Member
Join Date: Nov 2006
Location: Rochester, NY
Posts: 180
junkmonkey is an unknown quantity at this point
Default RE: Rear Wiper Blade Problems

Do you hear any clicking sounds? You'd know it if it was. It is possible that the shaft that passes through a sleeve from inside of the vehicle to the outside of the vehicle is hanging up (corrosion, rust). You can take the gear box apart and clean the shaft, relube it and re-assemble it. Not too bad of a job. The motor, too, could be flaky, of course. That's easy enough to test though by removing it and putting power to the contacts. It'll run or not. Good Luck.

Another thing: The plastic gears could be stripped inside the gear box (if it doesn't click).
 
  #4  
Old 10-17-2007, 01:42 PM
Beginning Member
Join Date: Nov 2006
Location:
Posts: 22
UrbanOffRoader is an unknown quantity at this point
Default RE: Rear Wiper Blade Problems

I have this same issue...

The shaft tends to rust and cause it to stick, which in turn causes the crappy plastic gear to strip a tooth or two.

Pulling it apart and re-lubing it will help if the gear isn't stripped. If the gear is stripped, you will need a new motor. I haven't seen the $0.27 plastic gear for sale on it's own.
 
  #5  
Old 10-18-2007, 02:44 PM
Junior Member
Join Date: Feb 2007
Location:
Posts: 251
blzR is an unknown quantity at this point
Default RE: Rear Wiper Blade Problems

Just do what i did,after my wiper "tried" to do it's wiping duties,and stopped midway..replace the entire unit($80)
- lower tailgate,remove 2edge phillipe screws,remove both handle screws,Gentlypull panel off there clips
-remove the 11/12 7mm screws,take off wiper assembly,unbolt 3 10mm wiper housing and assemble in reverse.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jpmccr
2nd Gen S-series (1995-2005) Tech
8
05-01-2010 10:25 AM
The_Beast
General Chat
2
07-27-2009 08:13 PM
Tippman7641
2nd Gen S-series (1995-2005) Tech
14
02-21-2008 10:57 AM
lionel2
2nd Gen S-series (1995-2005) Tech
4
02-17-2008 02:06 PM
speeddemon560
Engine & Internal
9
02-16-2007 12:47 AM


Thread Tools
Search this Thread
Quick Reply: Rear Wiper Blade Problems


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.