Go Back   Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > General Tech Help > 2nd Gen S-series (1995-2005) Tech
Sign in using an external account
Register Forgot Password?
Search


Welcome to Blazer Forum!
Welcome to Blazer Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Blazer Forum today!


Closed Thread
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-29-2008, 11:31 PM
 
Join Date: Apr 2008
Location:
Posts: 2
brooks66 is an unknown quantity at this point
Default 1996 ecm fuse keeps blowing

hey guys my name is joe and i have a 1996 chevy blazer 4.3 vortec and the ecm fuse keeps blowing i already replace 3 relays thinking that would work and it didnt. i did have a new alternator put in it and i found two wires that were saughtered really good idk if that could be causing but the truck does turn over it just not staying started it blows the fuse automaticly i need help really bad.
__________________
Joseph S. Brooks
  #2  
Old 05-01-2008, 06:32 AM
Beginning Member
 
Join Date: May 2008
Location:
Posts: 39
Kimchoc is an unknown quantity at this point
Default RE: 1996 ecm fuse keeps blowing

Joe, I am having the EXACT same problem! I am at stoplight, I go to accel and the car dies. Fuse blown. 3rd time now. I also get a skip when driving interstate speeds. Only a slight blip but certainly feels like it dies for one split second.



We need help please..

Gary B.
__________________
96 S-10 Blazer 4.3-4wd, '00 S-10 Blazer 4.3-4wd, 79 K-10 4wd, NAISE certified 1974-1979. Chevy preferred.
  #3  
Old 05-06-2008, 03:18 PM
 
Join Date: Apr 2008
Location:
Posts: 2
brooks66 is an unknown quantity at this point
Default RE: 1996 ecm fuse keeps blowing

hey did u figure ur problem out yet because i am almost to the point of taking it to someone but i have this feeling its going to be something simple
__________________
Joseph S. Brooks
  #4  
Old 05-07-2008, 05:40 AM
Beginning Member
 
Join Date: May 2008
Location:
Posts: 39
Kimchoc is an unknown quantity at this point
Default RE: 1996 ecm fuse keeps blowing

I dont know for sure. I had it in for the problem(no start) at the dealership and they claimed it was a timing chain. I didnt know about eh fuse before I had it towed there. I was a bit suspicious on that diagnosis but it ran when I picked it up. It cut off on the way home. Then again a day later. Then it cut off one more time and didnt start 200 miles after the repair. I diagnosed the fuse and it started right up. It cut off and blew the fuse one more time, right on acceleration from stoplight(exactly like all the other cut off times) and that made me very suspicious about eh timing chain repair for 1600.00. It has not run right since the repair. It ALWAYS ran perfect.
I went to junkyard and bought a computer and a MAF sensor for 58.00. I put the MAF sensor on and it hasnt blown yet. The dealership also put in new spark plugs. Never really understood why. I checked and they put in AC platinum plugs. I dont think I like them so I put in good ol regular AC plugs the other day.
No problems so far. But its only been a few days and maybe 80 miles.
My method of repair is to replace things. So far, plugs, MAP, MAF , cap rotor. I also took off the ignition module and cleaned the heat past and applied new just in case it was overheating and causing the issue. Cheap fix.
I'm trying to eliminate things. Fuel test says OK on the guage and I replaced the pump a year and a half ago.
Hope something helps.. my next step is a different dealer and a diagnosis check only. And I'll be there when its being done and they wont do anything else but that. I hope they can qualify some things for me. I'm suspicious of the fuel pressure regulator.
I've read every forum I can find but no good answers..
kimchoc...yahoo.com
__________________
96 S-10 Blazer 4.3-4wd, '00 S-10 Blazer 4.3-4wd, 79 K-10 4wd, NAISE certified 1974-1979. Chevy preferred.
Old 05-07-2008, 05:40 AM
 
 
 
Closed Thread

Tags
1995, 1996, 2000, 2001, 95, 96, blazaer, blazer, blowing, blown, blows, chevy, ecm, fuse, show


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors

All times are GMT -5. The time now is 02:47 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.