Blinker problems - Blazer Forum - Chevy Blazer Forums


2nd Gen S-series (1995-2005) Tech Discuss 2nd generation s-series (1995-2005) general tech topics here.

Closed Thread
 
 
 
Thread Tools Search this Thread
  #1  
Old 12-13-2006, 06:05 PM
Starting Member
Thread Starter
 
Join Date: Jul 2006
Location: Republic
Posts: 136
mrspeedy69 is an unknown quantity at this point
Default Blinker problems

Ok i have a few questions. I have a 97 4dr 4wd Blazer. First off i was wondering if anybody has used seafoam and if there was an easy way of getting it into the intake. I know old carb motors you could pour it in there. But not sure about fuel injection. Or if seafoam is even any good, i heard it was but wasn't sure.

Also my blinkers just quit working. My headlights, and break lights work but when i turn my blinkers on nothing happens. They don't flash on the dash or outside.

Lastly i was wondering if anybody had any problems with their blazer not warming up very good. It's kind of cold right now where i'm at and i can drive my blazer all day long and the temp guage hardly moves at all. When it's warmer outside it will always warm up to about the first notch (not sure how hot that is) But when it's cold it doesn't hardly move at all. So is there maybe something wrong or is that normal. Is there anyway i could get it to warm up better?
  #2  
Old 12-13-2006, 06:15 PM
swartlkk's Avatar
Administrator
 
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,510
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default RE: Blinker problems

About seafoam, I have used it on every vehicle I have owned for a long time. I believe that if you unplug your MAF sensor and remove the intake duct work, you can just pour it down the throttle body. On my Bravada, I used the PCV vac line to suck it into the intake, but I didn't unplug the MAF sensor so the truck kept on dying on me.

On the blinkers, you probably need a new relay. Do your 4-ways work?

About the not warming up, it is quite possible that your t-stat has stuck open and is not allowing the motor to fully warm up. How is your gas mileage? Does the heater put out decent heat? Is the upper radiator hose hot?
  #3  
Old 12-13-2006, 07:06 PM
Starting Member
Thread Starter
 
Join Date: Jul 2006
Location: Republic
Posts: 136
mrspeedy69 is an unknown quantity at this point
Default RE: Blinker problems

Yeah my 4way hazards blink just fine, but the actual blinkers wont come on when i try them. Could it be that the blinker switch is bad? I mean everything else on there works the wipers and cruise and all that just not the blinkers?

With the warming up the upper radiator hose feels hot. But my gas mileage isn't very good, it snowed a while back and i was using 4wd but i think i averaged around 11-12mpg. Right now driving just normal i get like 15-16 and thats even on the highway. I didn't think this was very good but i wasn't sure how good they were suppose to get. The heater is somewhat warm, its not as warm as it could be i don't think.
  #4  
Old 12-13-2006, 09:05 PM
 
Join Date: Jul 2006
Location:
Posts: 137
magnum434 is an unknown quantity at this point
Default RE: Blinker problems

your out of blinker fluid....durrrr......lol jkbut really....you need a new flasher relay located directly behind the cigarette lighers. I'm kinda wondering if I need a new T-stat...I replaced it not too long ago when I got it a year ago...but since then have had the intake gasket replaced. Would this effect my t-stat? I've been gettin about 12 mpg and according to the temp gauge, it never goes over the 1/4 mark.....160ish??? i dont know....Its never even been remotely close to 210....never ever...help me out
  #5  
Old 12-13-2006, 09:18 PM
swartlkk's Avatar
Administrator
 
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,510
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default RE: Blinker problems

If the temperature never goes over somewhere in the 170*F range, it won't move out of the fuel enrichment mode. That is why I asked about the mileage. But at 15-16mpg, that doesn't sound horrible. 12mpg does...
  #6  
Old 12-13-2006, 10:32 PM
 
Join Date: Jul 2006
Location:
Posts: 137
magnum434 is an unknown quantity at this point
Default RE: Blinker problems

what isthe quarter mark temperature on a 96 blazer actually reading???
  #7  
Old 12-13-2006, 11:46 PM
Starting Member
Thread Starter
 
Join Date: Jul 2006
Location: Republic
Posts: 136
mrspeedy69 is an unknown quantity at this point
Default RE: Blinker problems

Yeah my blazer has never gotten close to the 210 mark except one time when it was almost 90 outside and it was idleling for over an hour. So could that be the thermostat sticking open? And about the blinkers, so that sounds like the blinker relay under the dash?
  #8  
Old 12-14-2006, 12:08 AM
 
Join Date: Jul 2006
Location:
Posts: 137
magnum434 is an unknown quantity at this point
Default RE: Blinker problems

yea...there will be 2 different ones that are pretty similar...i think its the smaller one...on the right... center dash
  #9  
Old 12-14-2006, 02:08 PM
Starting Member
Thread Starter
 
Join Date: Jul 2006
Location: Republic
Posts: 136
mrspeedy69 is an unknown quantity at this point
Default RE: Blinker problems

Ok i found them. Do they just pull out or is there a trick to it. I was afraid to pull too hard i didn't want to break anything.
  #10  
Old 12-14-2006, 03:38 PM
 
Join Date: Jul 2006
Location:
Posts: 137
magnum434 is an unknown quantity at this point
Default RE: Blinker problems

yea..pull straight out...
 
 
Closed Thread

Related Topics
Thread Thread Starter Forum Replies Last Post
96 s10 blazer blinker problems Jeremy Whitcomb Lighting & Electrical 3 02-05-2013 06:51 PM
Random "blinker" sound and right blinker indicator stays on blazintexas 2nd Gen S-series (1995-2005) Tech 2 05-01-2012 06:01 AM
Fuse/AC/ Blinker problems please help blazin hot Lighting & Electrical 0 07-17-2011 01:17 PM
blinker issue eightyninegt Full Size K5 Tech 11 01-30-2010 02:25 PM
60/40 seat/blinker noise JHAMIL 2nd Gen S-series (1995-2005) Tech 5 12-06-2006 05:02 PM


Tags
1996, 96, blazer, blazerblinkers, blinker, chevrolet, chevy, diagram, dont, lt, problems, relay, sticking, troubleshooting, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:21 AM.