? dead battery - Blazer Forum - Chevy Blazer Forums


2nd Gen S-series (1995-2005) Tech Discuss 2nd generation s-series (1995-2005) general tech topics here.

Closed Thread
 
 
 
Thread Tools Search this Thread
  #1  
Old 10-13-2007, 02:24 PM
Thread Starter
 
Join Date: Aug 2006
Posts: 17
silentknight is an unknown quantity at this point
Default ? dead battery

we have a 2000 blazer this am used it to "jump start" 2003 chevy silverado truck now blazer will not start. sounds like it wants to turn over but will not actually start. charged battery and still nothing. any ideas ????? thanks
  #2  
Old 10-13-2007, 02:38 PM
BF Veteran
 
Join Date: Jun 2006
Location: Vancouver. B.C. Canada
Posts: 3,429
Chevy Lover is a jewel in the roughChevy Lover is a jewel in the roughChevy Lover is a jewel in the rough
Default RE: ? dead battery

Did you have the Blazer running during the jump start or was the engine off?
You should probably check for a broken fusible link near the starter motor. T he ffusible link will usually burn the wire and not break the insulation so they can be hard to detect, I usually give them a little tug and if they stretch they're probably burned.
  #3  
Old 10-13-2007, 03:27 PM
Administrator
 
Join Date: Nov 2005
Location: Zanesville oHIo
Posts: 2,931
hillbillyinOhio has disabled reputation
Default RE: ? dead battery

good connection at the battery??? check for cracks and corrosion at the terminals as well
  #4  
Old 10-13-2007, 04:02 PM
New Member
 
Join Date: Jul 2007
Location:
Posts: 68
megtom2 is an unknown quantity at this point
Default RE: ? dead battery

My blazer has been a battery killer ever since we bought it 10 years ago. We have probably gone through 6 batteries. No, we don't sit around with the radio blaring and the engine off. It just eats them up.
  #5  
Old 10-13-2007, 04:03 PM
Thread Starter
 
Join Date: Aug 2006
Posts: 17
silentknight is an unknown quantity at this point
Default RE: ? dead battery

Blazer was running when we jumped off truck, wife was in Blazer giving more rpms. Blazer will turn over good, just seems like no fire.

Exactely where is fusible link and what might it look like?

Thx for replies.
  #6  
Old 10-13-2007, 04:04 PM
Administrator
 
Join Date: Nov 2005
Location: Zanesville oHIo
Posts: 2,931
hillbillyinOhio has disabled reputation
Default RE: ? dead battery

then you have something that is drawing on the battery when off. best bet would be check the current drawas you start removing fuses!
  #7  
Old 10-13-2007, 10:14 PM
mdehoogh's Avatar
Super Moderator
 
Join Date: May 2007
Location: Chicago, IL
Posts: 2,708
mdehoogh has a brilliant futuremdehoogh has a brilliant futuremdehoogh has a brilliant futuremdehoogh has a brilliant futuremdehoogh has a brilliant futuremdehoogh has a brilliant futuremdehoogh has a brilliant futuremdehoogh has a brilliant futuremdehoogh has a brilliant futuremdehoogh has a brilliant futuremdehoogh has a brilliant future
Default RE: ? dead battery

mine eats batteries too, im on my 3rd in two years. during winter time especially when rainy, my brake pedal seem to not come up all the way when i turn the truck off and the brake lights will be on all day long
  #8  
Old 10-14-2007, 01:18 AM
Thread Starter
 
Join Date: Aug 2006
Posts: 17
silentknight is an unknown quantity at this point
Default RE: ? dead battery

Any other suggestions as to what we may have fried when using our Blazer to jump-start Silverado Z71?
  #9  
Old 10-14-2007, 07:17 PM
Super Member
 
Join Date: May 2007
Location: Appleton, WI / Houghton, MI
Posts: 1,980
lennyblazer is on a distinguished road
Default RE: ? dead battery

I would make sure all your connections are still good. Even if there is little to no corrosion on the outside of the terminal posts, there could be a bad connection. I would take the leads off the battery and clean all the terminals and the posts and screws realy good with wire brushes. Then get a corrosion resistant felt or spray to keep it from corrotion build up. This happened to me this summer when I was jumpstarting someone.
  #10  
Old 10-14-2007, 09:02 PM
BF Veteran
 
Join Date: Jan 2007
Location: GP AB CA
Posts: 3,946
drperry is a jewel in the roughdrperry is a jewel in the roughdrperry is a jewel in the rough
Default RE: ? dead battery

Check your fuel pump relay and fuses and PCM/ECM fuses as well, just in case...
 
 
Closed Thread

Related Topics
Thread Thread Starter Forum Replies Last Post
dead r12 system to r134 conversion dead in water help ac techs 94s10blazin 1st Gen S-series (1983-1994) Tech 4 08-10-2013 01:00 PM
Random dead battery/Won't start twilkinson3 2nd Gen S-series (1995-2005) Tech 9 11-10-2009 06:26 PM
I think my battery is dead... Zasder General Chat 6 11-14-2007 04:44 PM
Dead People and Dead Batteries rriddle3 General Chat 10 08-26-2007 04:38 PM
Dead Battery brownblazer 1st Gen S-series (1983-1994) Tech 3 09-12-2005 06:55 PM


Tags
2000, battery, blazer, burning, chevrolet, dead, died, fuse, jump, link, silverado, started, starter, starting, wires

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:13 PM.