Engine & Transmission Post your Engine and Transmission related problems here.
Sponsored by:
Sponsored by:

Skipping and backfiring above 3K rpms ???

  #1  
Old 03-09-2018, 07:57 AM
danix803's Avatar
New Member
Thread Starter
Join Date: Feb 2018
Posts: 7
danix803 is on a distinguished road
Question Skipping and backfiring above 3K rpms ???

I know a little about engines, but sometimes I can't see the forest for the trees. So, I could use a little sagely advice from a pro or two about this.
My '98 blazer, when I accelerate a little hard, runs great until it gets above 3K rpms. Then, it stars popping a little (once or twice) shudders and starts accelerating fine.
At first, I thought, fuel pump. Because I've had some trouble with these fuel pumps on a few blazer. I've owned 4 and still have 2 of them. Looking for another one. But, I really like this one and have replaced the engine, rebuilt the transmission, and am still working a few other things (cosmetic).
Anyway, what do you think would cause this?
Any constructive assistance is greatly appreciate... Thanks in advance... :-)
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
taylort232
2nd Gen S-series (1995-2005) Tech
3
09-20-2011 08:43 AM
Big Country
Engine & Transmission
0
08-07-2011 02:16 AM
BubbaBrooks
2nd Gen S-series (1995-2005) Tech
4
11-19-2010 09:02 AM
BuckyBoy
1st Gen S-series (1983-1994) Tech
3
09-05-2007 09:09 PM
Lockback
1st Gen S-series (1983-1994) Tech
4
08-22-2007 12:24 PM


Thread Tools
Search this Thread
Quick Reply: Skipping and backfiring above 3K rpms ???


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.