Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

89 K5 Blazer cranks but won't start

  #1  
Old 06-12-2010, 04:19 PM
New Member
Thread Starter
Join Date: Jun 2010
Posts: 5
triplethreat is on a distinguished road
Unhappy 89 K5 Blazer cranks but won't start

Help looking for some good advice here. I've got a 89 Blazer 350 with TBI. The Blazer cranks over but won't start. If I spray carb cleaner down the throat she starts. I've checked the fuel pump and relay they are good. I've hooked up a scan tool and no error codes. I've replaced the ECM twice and the ICM once. If I unplug the computer and ground one of the injectors she starts and runs just fine. This rules out a bunch of stuff. I even did this with the other injector and it runs. The TPS is showing about .5 volts. If I apply 12 volts to the reference connector on the computer the lead that goes to the ICM this will trigger the fuel pump but not the injectors. Ive checked and the computer is well grounded. Any ideas??
 
  #2  
Old 06-12-2010, 07:09 PM
bandidolenny's Avatar
Super Member
Join Date: Jan 2009
Location: Kerrville, Texas
Posts: 1,349
bandidolenny is on a distinguished road
Default

Bad computer?
 
  #3  
Old 06-12-2010, 09:43 PM
Ck1500's Avatar
Starting Member
Join Date: May 2010
Posts: 108
Ck1500 is on a distinguished road
Default

the computer reads alot of things, to tell the truck what to do, one of the wierder things i have found with them is if your fuel pump is working and your injectors are spraying when you jump out the computer.. that there is a low oil safety that will shut the injectors off as a safety... i know it sounds strange but it worked on a 1988 K5 i had been working on in my garage.. "a customers not mine" i would rule the simple things like that out first.. because the computers are normally pretty tough on them . but it sounds like you have changed them out before, kinda makes me think there is posibly something else going on... giving the computer false info...

gonna have to sleep on this one ... and i will try to brainstorm other options too...

Ck1500
 
  #4  
Old 06-13-2010, 02:14 AM
New Member
Thread Starter
Join Date: Jun 2010
Posts: 5
triplethreat is on a distinguished road
Default

The oil safety switch only controls the fuel pump. I can bypass this super easy and the truck still won't start cause the fuel injectors aren't getting the negative pulse from the ECM.
 
  #5  
Old 06-13-2010, 02:15 AM
New Member
Thread Starter
Join Date: Jun 2010
Posts: 5
triplethreat is on a distinguished road
Default

I wish it was that easy but after replacing 2 of them I think my parts store would kill me if I asked for another. Its got to be something else just not sure what.
 
  #6  
Old 06-13-2010, 06:44 PM
New Member
Thread Starter
Join Date: Jun 2010
Posts: 5
triplethreat is on a distinguished road
Default

Put a new ignition module in it for the second time and still no go. This is really starting to stink. I had the original module tested at Autozone and it was bad. Hopefully I can get their tomorrow and have them test my two new ones.
 
  #7  
Old 06-14-2010, 08:55 PM
New Member
Thread Starter
Join Date: Jun 2010
Posts: 5
triplethreat is on a distinguished road
Default

In case anyone cares I had the two new ignition modules tested and they both came back fine. I checked the 4 wires running from the ICM to the ECM and they are fine. Checked the Grounds to the computer and they are fine. Running out of ideas
 
  #8  
Old 01-30-2011, 02:38 PM
Starting Member
Join Date: Jan 2011
Location: Ny
Posts: 3
K5chvygrl is on a distinguished road
Default

I am having the same problem with my 87, have you found anything else to try???
 
  #9  
Old 01-31-2011, 07:37 AM
Mighty Mouse's Avatar
New Member
Join Date: Dec 2010
Location: Carlisle, Pa
Posts: 51
Mighty Mouse is on a distinguished road
Default

I had a problem like that only it was intermittent. If I held the gas pedal to the floor I could get it to start. I checked the TPS and it was fine but I changed it anyhow and it cured the problem. Also when you turn the key on do you hear the fuel pump kick on for about 2 seconds?
 
  #10  
Old 01-31-2011, 08:14 AM
New Member
Join Date: Dec 2010
Location: Orlando
Posts: 62
IrvJr is on a distinguished road
Default

Originally Posted by Mighty Mouse View Post
Also when you turn the key on do you hear the fuel pump kick on for about 2 seconds?
Good idea. When you get it started with the starting fluid is any fuel coming out of the injectors? You seem to have checked alot. Have you tested the injector harness itself?
 

Thread Tools
Search this Thread
Quick Reply: 89 K5 Blazer cranks but won't start


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.