General Chat Chat about all things Blazer (and related vehicles). Off-topic stuff should be in the lounge, and all mechanical problems should be posted in the proper forum.

What is wrong with this 98 blazer?

  #1  
Old 06-02-2018, 04:01 PM
New Member
Thread Starter
Join Date: Jun 2018
Posts: 2
D Sun is on a distinguished road
Default What is wrong with this 98 blazer?

https://youtu.be/O2KgH2bpYgg

Makes this sound, after white/ gray smoke under hood and then just stopped running. Pulled it home. Not sure what's next... seemed like it overheated but no warning lights. Started to lose acceleration then the smoke and then it shut down. It starts now but this is what it sounds like.
 

Last edited by D Sun; 06-02-2018 at 04:19 PM. Reason: Correct description
  #2  
Old 06-03-2018, 03:38 PM
Super Member
Join Date: Nov 2016
Location: Ontario canada
Posts: 1,531
DonL is on a distinguished road
Default

Try loading the video again. It's not clickable
 
  #3  
Old 06-03-2018, 11:38 PM
christine_208's Avatar
BF Veteran
Join Date: Dec 2016
Location: Moscow, ID
Posts: 2,086
christine_208 is on a distinguished road
Default

Have you checked the oil for water? I've heard of the lower intake manifold (LIM) gaskets failing catastrophically dumping coolant into the lifter valley and oil pan which then causes the bearings to wear due to lack of oil.
 
  #4  
Old 06-05-2018, 04:56 AM
error_401's Avatar
Moderator
Join Date: Nov 2007
Location: Zurich
Posts: 1,114
error_401 is on a distinguished road
Default

https://www.youtube.com/watch?v=O2Kg...ature=youtu.be

Doesn't sound too good.
Vid is a bit too short and the squeaking of the belt covers some other noises.

To start with it looks and sounds as if not running on all 6 cylinders.
I cannot properly distinguish the knocking sound. Would be interesting to hear it on video when shot from below but could be an indication of a spun rod bearing.
Eventually also a leak in the exhaust headers.

Several questions:
When it happened you said you had white smoke. Also from the exhaust? Like a white smoke trail?

You opened the hood I guess as you said you had white smoke also from the engine bay. Did it feel hotter than you would eventually have experienced other cars?

How about your coolant temperature indication. Does it work?

You may want to find someone knowledgeable to have a look at it.
 
  #5  
Old 06-05-2018, 07:40 AM
New Member
Thread Starter
Join Date: Jun 2018
Posts: 2
D Sun is on a distinguished road
Default

Originally Posted by error_401 View Post
https://www.youtube.com/watch?v=O2Kg...ature=youtu.be

Doesn't sound too good.
Vid is a bit too short and the squeaking of the belt covers some other noises.

To start with it looks and sounds as if not running on all 6 cylinders.
I cannot properly distinguish the knocking sound. Would be interesting to hear it on video when shot from below but could be an indication of a spun rod bearing.
Eventually also a leak in the exhaust headers.

Several questions:
When it happened you said you had white smoke. Also from the exhaust? Like a white smoke trail?

You opened the hood I guess as you said you had white smoke also from the engine bay. Did it feel hotter than you would eventually have experienced other cars?

How about your coolant temperature indication. Does it work?

You may want to find someone knowledgeable to have a look at it.
Didn't notice any smoke from the exhaust, but it was pretty hot under hood. After changing a pulley and water pump out, still getting some white smoke and squeeling, but knocking not so much. The engine light works, none of the other lights have come on. Code that did come up prior to this was P0306
 
  #6  
Old 06-06-2018, 04:12 AM
error_401's Avatar
Moderator
Join Date: Nov 2007
Location: Zurich
Posts: 1,114
error_401 is on a distinguished road
Default

The temperature gauge works?
 
  #7  
Old 06-06-2018, 04:36 AM
error_401's Avatar
Moderator
Join Date: Nov 2007
Location: Zurich
Posts: 1,114
error_401 is on a distinguished road
Default

Next free steps may be:

Check oil (water in oil) quantity, looks, smell
Check radiator and expansion bottle levels, looks, smell of coolant (at cold engine - safety concern)

Water in the oil or oil in the coolant may get you a distinctive (chocolate milk-shake) look but not in any case. We have seen cases where the oil looked normal at first but was full of coolant.

Check all 6 spark plugs, boots, wires.
If all plugs are out it may be worth seeing if you can get a compression tester.
(With all plugs out test each cylinder in turn.)
Check distributor cap and rotor, contacts and clean out

Go from there on what you find.

Next steps involving a bit more labor and eventually a cost:

Code reader and read all ECM codes. Note. Reset. Start up and re-read all codes.

Don't run the engine for long it sounds bad enough not to take risks before the cause is determined.

May want to drain all the oil into a transparent container and see if it settles in two layers.
Remove the oil filter and cut it open (don't cut your fingers) to see what's trapped inside.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
199634
2nd Gen S-series (1995-2005) Tech
4
04-20-2011 02:09 PM
Bybsurfr32
2nd Gen S-series (1995-2005) Tech
1
09-16-2009 07:19 PM
jonesjt
2nd Gen S-series (1995-2005) Tech
19
02-20-2009 10:39 AM
chevblazer02
General Tech Help
1
10-31-2006 12:09 AM


Thread Tools
Search this Thread
Quick Reply: What is wrong with this 98 blazer?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.