General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here.

Starting Problems 2004 Blazer

 
 
 
 
  #1  
Old 11-22-2006, 02:48 AM
Thread Starter
Join Date: Nov 2006
Location:
Posts: 3
Chev it or leave it is an unknown quantity at this point
Default Starting Problems 2004 Blazer

I have a 2004 Blazer that is having intermittent starting problems. Most of the time it happens when it gets less than a quarter tank of gas, but tonight it happened with more than a half tank, but it was parked on a slant. My though is it is either the fuel filter or something in the tank clogging the line. When the problem starts, it will start to fire when you first hit the ignition, then it just continues to turn over with no fire. It will continue to do this until the battery goes dead, then after sitting for a while and a jump start, it will fire up fine and then run fine. I was just wondering if anyone else has experienced this, or if there are any other suggestions you can give. I will be taking it in to get a code scan done as well just to check. I appreciate any feedback you can give me.
 
  #2  
Old 11-22-2006, 03:25 AM
Join Date: Mar 2006
Location: Anchorage, AK
Posts: 51
kaindragoon36 is an unknown quantity at this point
Default RE: Starting Problems 2004 Blazer

Do the guages react? Do you hear your fuel pump whirring? Do you hear a click that sounds like its coming from your glovebox??
 
  #3  
Old 11-22-2006, 03:48 AM
Thread Starter
Join Date: Nov 2006
Location:
Posts: 3
Chev it or leave it is an unknown quantity at this point
Default RE: Starting Problems 2004 Blazer

Yes the gauges react, I can hear the fuel pump running, and I didn't hear any clicking in the glovebox area, but I wasn't really listening for it. It acts almost normal and starts to fire, but won't fire completely and stay running, and again it is intermittent, which makes it that much more frustrating.
 
  #4  
Old 11-22-2006, 10:08 AM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,802
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default RE: Starting Problems 2004 Blazer

Next time it does this, try turning the key to the run position and leave it there for a good bit of time, then try to start it. This will allow the fuel pump to prime. If that doesn't help, then you may need to get the fuel pressure tested.
 
 
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
John Pack III
2nd Gen S-series (1995-2005) Tech
1
01-13-2014 10:28 AM
kzooblazer
General Chat
3
08-18-2013 07:56 PM
MTopper
Audio/Video Electronics
74
07-12-2011 12:19 AM
cgrett
2nd Gen S-series (1995-2005) Tech
9
11-15-2010 09:08 PM
Sprocket
2nd Gen S-series (1995-2005) Tech
1
03-20-2008 09:39 PM


Thread Tools
Search this Thread
Quick Reply: Starting Problems 2004 Blazer


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.