95 Blazer issue please help - Blazer Forum - Chevy Blazer Forums


Lighting & Electrical Post your lighting and chassis/engine electrical questions here. Any audio/video questions should be posted in the 'Audio/Video Electronics' section.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 10-11-2017, 05:08 PM
Starting Member
Thread Starter
 
Join Date: Oct 2017
Posts: 1
Wildhorse66 is on a distinguished road
Exclamation 95 Blazer issue please help

I recently replaced the ignition cylinder and key for my Blazer with OEM parts, original key would not disengage steering lock or start. My vehicle started and ran perfectly first time, now I get no dashboard indicators and engine won't fire. Radio turns on and light for transmission select turns on gauges work but no other indicators light up, as a result no fire. Battery is new and fully charged, fuses are all okay (tested) engine won't fire under boost either as no dash lights. Help please...
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
93 blazer 4l60e transmission issue, please help!! astro209 Engine & Transmission 3 08-25-2013 01:24 PM
2000 blazer braking issue - please help Blueblazer45 2nd Gen S-series (1995-2005) Tech 2 04-22-2013 08:47 PM
93 blazer w vin, running and starting issue (Lots of info long read)please help! serrasalmus 1st Gen S-series (1983-1994) Tech 9 02-20-2011 11:20 PM
2000 Blazer Air Conditioning Issue Please Help roccorizer 2nd Gen S-series (1995-2005) Tech 1 07-22-2009 03:55 PM
fuel pump help please,,please,,please rogggg1020 Engine & Transmission 8 11-11-2008 08:05 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 09:24 PM.