Lighting & Electrical Post your lighting and chassis/engine electrical questions here. Any audio/video questions should be posted in the 'Audio/Video Electronics' section.

Rear wiper is not working on 1998 Blazer

  #1  
Old 05-15-2019, 10:07 PM
New Member
Thread Starter
Join Date: May 2019
Posts: 6
Small Arms Collector is on a distinguished road
Default Rear wiper is not working on 1998 Blazer

When I try to turn on my rear wiper it just makes a horrible and LOUD sound, but does not move, any ideas what might be wrong? Iím not too worried about the rear wiper, but it would be nice if it worked.

Iím assuming itís jammed? What might it be sticking on? Can I easily unjam it?

Completely unrelated question, but not really worth another thread, the plastic trim around my seat controls is coming loose, how can I fix it? Or find a replacement piece? Likewise, the trim on the driverís door feels like it is flexing and moving when the window goes up or down, any ideas?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Lighting & Electrical
0
03-20-2014 10:26 PM
Helter80
2nd Gen S-series (1995-2005) Tech
2
06-14-2013 08:34 PM
babeba67
2nd Gen S-series (1995-2005) Tech
3
01-08-2013 08:03 PM
IrishDrums85
2nd Gen S-series (1995-2005) Tech
2
11-30-2011 10:56 AM
ussexplorer
Lighting & Electrical
8
06-08-2011 08:14 PM


Thread Tools
Search this Thread
Quick Reply: Rear wiper is not working on 1998 Blazer


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.