Paint, Body, & Interior Need advice on paint? Have a new interior mod idea? Having some trouble with a body kit? Discuss it here.

03 blazer Instrument cluster

  #1  
Old 06-26-2018, 10:44 AM
Beginning Member
Thread Starter
Join Date: Jun 2018
Location: North Carolina
Posts: 48
Bepjer28 is on a distinguished road
Default 03 blazer Instrument cluster

I'm looking at possibly replacing the whole cluster. First off i have a bulb that's out and was thinking or replacong them with blue LEDs... If this is possible what size bulbs do i need and where can i find these... Also i would like to replace all the guages with white faces.. Once again after an exhausting search I've found nothing to fit my blazer... Any ideas would be helpful...
 
  #2  
Old 07-02-2018, 04:59 PM
Super Member
Join Date: Nov 2016
Location: Ontario canada
Posts: 1,443
DonL is on a distinguished road
Default

I think the s10 extreme models had the white backing, can't remember exactly. And if you do a search on here for the cluster exchange, there's a write up. Can't remember exactly by whom, but I know of at least 2 different people who I'd this. Good luck, post pics when your done if you don't mind, wouldn't mind seeing the blue behind the white... seen many black on blue.
 
  #3  
Old 07-05-2018, 09:35 PM
N. Jensen's Avatar
Senior Member
Join Date: Nov 2014
Location: Iowa
Posts: 756
N. Jensen is on a distinguished road
Default

Check out this build thread. Tajohns34 gets into detail with different Blue LEDs, and a color changing gauge face.

https://blazerforum.com/forum/builds...r-build-79095/

Otherwise, you can order generic white faced gauge plates like the following:

https://www.bonanza.com/listings/98-...yABEgLFg_D_BwE

Ebay might have cheaper, and different styled ones.
 
  #4  
Old 07-16-2018, 08:56 AM
Beginning Member
Thread Starter
Join Date: Jun 2018
Location: North Carolina
Posts: 48
Bepjer28 is on a distinguished road
Default Update

I just replaced the bulbs with some blue leds... They don't work at all... I just got in another set and haven't installed them yet... I tested the original bulbs that work but when I put the meter to the led's they don't register... I was wondering if there is a way to test them to see if the work...
 
  #5  
Old 07-16-2018, 09:22 AM
N. Jensen's Avatar
Senior Member
Join Date: Nov 2014
Location: Iowa
Posts: 756
N. Jensen is on a distinguished road
Default

Originally Posted by Bepjer28 View Post
I just replaced the bulbs with some blue leds... They don't work at all... I just got in another set and haven't installed them yet... I tested the original bulbs that work but when I put the meter to the led's they don't register... I was wondering if there is a way to test them to see if the work...
You might have to flip the LEDs around to get them to work.
Also, when you put them in your cluster, you might have to only twist them 75 percent of the way. Make sure the metal tabs on the twist base are touching the metal strips on the cluster.
 
  #6  
Old 07-16-2018, 03:52 PM
Beginning Member
Thread Starter
Join Date: Jun 2018
Location: North Carolina
Posts: 48
Bepjer28 is on a distinguished road
Default

I have tried flipping them and still nothing... There are 6 that go in the cluster so the odds of them all being backwards are small... But nonetheless I turned 3 of them 180... I'd be done sooner but my battery died and since i can't legally drive it I haven't been able to get it charged... I'm about to take it to autozone to charge it... Upon further inspection it looks like the contacts go too far... I adjusted 2 of them and will check when I jump the blazer...
 

Last edited by Bepjer28; 07-16-2018 at 05:06 PM.
  #7  
Old 07-16-2018, 06:46 PM
Beginning Member
Thread Starter
Join Date: Jun 2018
Location: North Carolina
Posts: 48
Bepjer28 is on a distinguished road
Default Yay...

I got them to work... Well one of them... I didn't turn it as far and it works...
 
  #8  
Old 07-16-2018, 10:00 PM
N. Jensen's Avatar
Senior Member
Join Date: Nov 2014
Location: Iowa
Posts: 756
N. Jensen is on a distinguished road
Default

Saweet!

I like the blue, but the red matched better in mine.
 
  #9  
Old 07-17-2018, 03:17 AM
GreenBlazer2002's Avatar
Senior Member
Join Date: Oct 2016
Location: Thomson, Ga.
Posts: 508
GreenBlazer2002 is on a distinguished road
Default

Originally Posted by N. Jensen View Post
Saweet!

I like the blue, but the red matched better in mine.
And here we have green LED on white face gauges. 😎
 
  #10  
Old 07-17-2018, 03:29 AM
Cimmerian's Avatar
New Member
Join Date: May 2018
Location: Palm Beach, FL
Posts: 88
Cimmerian is on a distinguished road
Default

Originally Posted by N. Jensen View Post
Saweet!

I like the blue, but the red matched better in mine.
What brand red LEDs did you use? I tried to do the same in my old 1998 Mustang, but none of the four different brands of LED bulbs I used were ever as bright as in your picture.
 

Thread Tools
Search this Thread
Quick Reply: 03 blazer Instrument cluster


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.