2nd Gen S-series (1995-2005) Tech Discuss 2nd generation s-series (1995-2005) general tech topics here.

1997 4 door 4wd Service Engine Light Questions

  #1  
Old 02-07-2006, 02:41 AM
Thread Starter
Join Date: Feb 2006
Location:
Posts: 3
drumzandrekkids is an unknown quantity at this point
Default 1997 4 door 4wd Service Engine Light Questions

greetings everyone.

let me start by apologizing for only briefly searching this board for related information, and for such a long post.



i am new to this board as of tonight and am turning to anyone willing to offer insight as to my inquiries. i posted a thread in the new member's area, but to start, i really dont know much about cars besides how to drive them. being a modern day dude that is kind of embarrasing but hey i can't help that now. i know something is wrong with my truck and i want to go to the dealer at least reasonably informed about what the problem could be, seeing as though i am a pretty broke musician and rely on my truck to get us to and from gigs, this is a relatiely serious issue for me.

about a month ago, i noticed that my trunk had a marked lack of acceleration when accelerating from a stop light. this was a one time occurence. about a week later it happened a few times while driving. i spoke with some friends and they suggested perhaps a clogged fuel filter. i took it to Autozone last friday (which during the trip there and back did not experience the problem) to have the Service Engine codes scanned in this is what was returned:


P-0740 = the pcm has determined that a malfunction exists in the electrical circuit for the torque converter clutch.

P-0753 = the pcm has detected a short to ground, a short to battery, or an open circuit condition in the electrical circuit for shift solenoid "A".

P-0758 = the pcm has detected a short to ground, a short to battery, or an open circuit condition in the electrical circuit for shift solenoid "B".

P-0785 = the pcm has determined that a malfuunction exists in the electrical circuit for the shift timing solenoid.



tonight i drove to an obligation and experienced no problems. on the way home however, from being stopped at a light or stop sign for instance, there was a total lack of acceleration the whole way home. being worried i started searching the web for those codes. problem is most posts i found contained only one or two of those codes.

i found a variety of things that could be wrong, ranging from one person who said they replaced their ignition switch and the problem was solved. another person took it to their dealer who replaced the alternator and the problem was fixed. from what i gather basically the car has some type of issue shifting from 1st to 2nd gear, which makes the following thing the most interesting thing i found.

some one mentioned that due to an electronic engine sensor or whatever, the car detected a problem and locked the tranny in 2nd gear, so that the car would not get completley destroyed driving everywhere in 1st gear.

so that's basically what my automobile-ignorant self found out about what could be going on. i would really appreciate any solid insight/advice or ideas that any of you might have.


again, sorry for the long post.
 
  #2  
Old 02-10-2006, 03:08 PM
Join Date: Feb 2006
Location:
Posts: 6
gravix is an unknown quantity at this point
Default RE: 1997 4 door 4wd Service Engine Light Questions

Does your truck have a tach (RPM Gauge)? If so, does the engine appear to shift through all 4 gears and the torque converter clutch engage at 45mph? If you don't have a tach, you can still check the shifting behavior, just turn off the radio, roll down the window, and listen to your engine speed. Count how many times the engine revs up and drops down from 0-50mph. If you can at least get an idea of what's going on ("it's starting in second gear and shifting to third but not to forth!" or something like that) then that might help a mechanic out.

A lack of off-the-line acceleration could definitely be caused by the car starting in second gear, but that wouldn't explain reduced acceleration at higher speeds. If your tranny is completely locked into second gear (as it would be if your transmission was in the "2" position), you will waste huge amounts of fuel and experience strong engine braking every time you let off the gas at speed. The engine will also be much louder than normal. You could check to see if it will go into first gear at all by putting the gear selector in "1" in a parking lot, but don't drive more then 10mph or for more than a minute or so in that mode.

From the DTCs you posted, it's clear that your computer is severely confused. Get service immediately. I don't think you have much chance of solving this one on your own. Good luck!
 
  #3  
Old 02-10-2006, 11:24 PM
Thread Starter
Join Date: Feb 2006
Location:
Posts: 3
drumzandrekkids is an unknown quantity at this point
Default RE: 1997 4 door 4wd Service Engine Light Questions

hey thanks a lot. after my research and the posts i've received on several messageboards, including yours, i am definately taking the car in for service as soon as i can. i start a new sales job next week that will involve a good amount of driving, so i'm not gonna mess around.

thanks again!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
parks336
2nd Gen S-series (1995-2005) Tech
11
10-25-2013 03:58 AM
Geir
2nd Gen S-series (1995-2005) Tech
0
10-09-2011 08:51 PM
2001 ZR2
Engine & Transmission
2
01-16-2010 12:39 PM
loppy crimp
2nd Gen S-series (1995-2005) Tech
4
09-11-2008 08:31 PM
sectshun8
2nd Gen S-series (1995-2005) Tech
11
01-15-2006 02:20 PM


Thread Tools
Search this Thread
Quick Reply: 1997 4 door 4wd Service Engine Light Questions


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.