2nd Gen S-series (1995-2005) Tech Discuss 2nd generation s-series (1995-2005) general tech topics here.

1999 Blazer "Service 4WD" msg - intermittent 4WD engagement. Possible solution.

  #1  
Old 10-09-2011, 08:51 PM
Starting Member
Thread Starter
Join Date: Oct 2011
Location: Norway
Posts: 1
Geir is on a distinguished road
Default 1999 Blazer "Service 4WD" msg - intermittent 4WD engagement. Possible solution.

Hello, everybody!
I've searched this forum and internet in general (google) to find a solution to my 4WD problem, but with no luck. However I've finaly solved my 4WD problem, and thought that it would be useful to others to read both the nature of the problem and the solution. The car is a 1999 Blazer with Autotrack (4 buttons on the selector switch in the dash)

Problem description: (symptoms occur alone or paired with one or more of the others...)
- Only av few of the diodes on the selector switch ligt up during start-up.
- TCCM "clicks" as normal.
- The car responds randomly when pushing the Auto, 2WD, 4Hi, 4Lo button. Somtimes it works, sometimes it don't.
- The switch sometimes seems to be stuck in Auto or 2Hi.
-"Serwice 4WD" msg lights up from time to time, but go away at restart.

Solution (in my case):
Snap then selector switch free from the dashboard and disconnect the two pluggs. Make sure that the pins at the back of the switch is not corroded. If OK, bend the pins slightly so that you get really good connection between the plug and the pins - take a look at the plug to determine witch way to bend the pins...

This was the simple solution to a problem that I've spent days figuring out. I've checked vakuum lines, front axle switch, vacuum actuator under the battery, the solenoid at the firewall and every other suggesion I've found on the internet. I've read postings about bad TCCM connections and defective switches, but I've not seen the interface betweeen the harness and the selector switch mentioned as a possible cause to 4WD malfunction. Anyway; the solution in my case was a faulty plug/selector switch intreface - perhaps it can be usefull to somebody some day.

PS. Sorry if my english is a little odd - im from norway....
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fixer34
2nd Gen S-series (1995-2005) Tech
1
07-28-2013 10:42 AM
dct73
Steering, Suspension & Drivetrain
3
01-22-2012 01:48 PM
2001 ZR2
Engine & Transmission
2
01-16-2010 12:39 PM
junkmonkey
2nd Gen S-series (1995-2005) Tech
5
01-19-2009 09:02 AM
filtalr
2nd Gen S-series (1995-2005) Tech
2
11-24-2007 12:07 AM


Thread Tools
Search this Thread
Quick Reply: 1999 Blazer "Service 4WD" msg - intermittent 4WD engagement. Possible solution.


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.