Audio/Video Electronics Wired up? If you have some sort of A/V modification let's hear about it here. Discussion of stock electrical problems should be done in the 'Lighting & Electrical' section.

Stereo Issues

  #1  
Old 11-23-2015, 04:26 PM
Beginning Member
Thread Starter
Join Date: Jun 2012
Posts: 13
brent1010 is on a distinguished road
Default Stereo Issues

Hi, I installed a Kenwood aftermarket stereo years ago in my 2002 Blazer. Most of the time things have been working fine. Over the past couple months I've been having the following issues.

1) Radio does not usually stay on when turning key to off position, sometimes it immediately shuts off, other times it takes a few seconds to a few minutes. It should stay on until I open the door. Also turning to accessory does not turn on stereo. All other electronics, lights, windows seem to work fine.

2) This is even more intermittent and rare, but sometimes when using the power windows the radio will restart (power off and power back on), sometimes it even seems to be consistent with applying the brake pedal.

3) When the above things are not happening all of my speakers are usually not working at once, some work others don't, and sometimes they all work and sound great. I have all the speakers homing back into an aftermarket amp and then speaker wire going to my aftermarket stereo from the amp.

Could this all possibly be related to a bad ground cable connection for my stereo?
 
  #2  
Old 11-24-2015, 10:03 AM
Toocute350's Avatar
Junior Member
Join Date: Oct 2015
Location: Louisiana
Posts: 322
Toocute350 is on a distinguished road
Default

That could be a number of things.How did you hook the wires from the new stereo to the factory wires?Did you use the aftermarket wire harness that comes with the install kit?Or did you just hog tie them together?What about the grounds for both amp and stereo..What are they grounded to..The grounds have to be connected to a clean area with no rust,paint or dirt in between the connections.There`s also a safety device that the factory installed with the factory radio`s,not sure what it`s called.I would suggest you to contact Crutchfield.com.They will be able to tell you more about this device I`m talking about.I`ve read that while replacing factory radio with a aftermarket radio,you will need to buy this device in order to be able to keep the same safety features you have now.Ex: Radio stays on for about 10 minutes, after you turn the ignition off,radio turns off when you open the door .
 
  #3  
Old 11-27-2015, 04:19 PM
Beginning Member
Thread Starter
Join Date: Jun 2012
Posts: 13
brent1010 is on a distinguished road
Default

I used the aftermarket wiring harness. I took the dash all apart again yesterday and looked at all the wiring. I noticed there are two black wires, are these both ground connections? Should I use them both to the ground wire on the harness?

I have to admit my ground for my amp wasn't the best. It is mounted to a bolt under one of the back seats. I cleaned off all the paint really well this time and will see if it helps.
 
  #4  
Old 12-01-2015, 04:42 PM
Beginning Member
Thread Starter
Join Date: Jun 2012
Posts: 13
brent1010 is on a distinguished road
Default

So far this has been working well since my last post. I really think it was the amp ground causing issues and not clean enough. Thanks!
 
  #5  
Old 12-01-2015, 05:51 PM
CWBDDSPC's Avatar
Senior Member
Join Date: Oct 2013
Location: Iowa
Posts: 542
CWBDDSPC is on a distinguished road
Default

Nice job, thanks for the update!
 
  #6  
Old 01-15-2018, 05:11 PM
New Member
Join Date: Aug 2017
Posts: 91
Besel53 is on a distinguished road
Default

Is there any way to replace the radio lights? Most of mine are burned out.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
chase91
Audio/Video Electronics
4
10-20-2013 12:52 PM
satphonebrad
2nd Gen S-series (1995-2005) Tech
4
08-01-2012 07:52 PM
evinrude
2nd Gen S-series (1995-2005) Tech
2
09-15-2010 10:37 AM
hyperlite_rider
Audio/Video Electronics
8
04-04-2005 02:43 PM
custom blazer
Audio/Video Electronics
2
12-28-2004 11:23 PM


Thread Tools
Search this Thread
Quick Reply: Stereo Issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.