Engine & Transmission Post your Engine and Transmission related problems here.
Sponsored by:
Sponsored by:

1999 ZR2 blazer 4.3l 2door lose power

  #1  
Old 01-04-2010, 03:00 PM
Thread Starter
Join Date: Jun 2008
Location:
Posts: 4
bear is an unknown quantity at this point
Unhappy 1999 ZR2 blazer 4.3l 2door lose power

My blazers check engine light came on and went off for a couple days. Now its on goes off sometimes but, the prob. is that it feels like iam pulling a trailer and wont shift into overdrive. Maybe a vaccum line or ect? Dose anyone have an answer.
 
  #2  
Old 01-04-2010, 03:10 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,778
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

The first order of business is to get the codes read. Even though the CEL has gone out, the previously set codes that caused the CEL to illuminate in the first place will be stored. Let us know what the specific codes are (Pxxxx, Cxxxx, Bxxxx, or Uxxxx where 'x's are the numbers).
 
  #3  
Old 01-05-2010, 01:26 PM
Thread Starter
Join Date: Jun 2008
Location:
Posts: 4
bear is an unknown quantity at this point
Default

It came up with code p0753 shift solenoid. I have done filter changes on older rigs could i do this my self?
 
  #4  
Old 01-05-2010, 02:51 PM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,778
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

P0753 - Shift Solenoid A Electrical

That will run you through the diagnostic steps. This code does not entirely mean that the shift solenoid is bad. It could be a damaged wiring harness inside the transmission or damage outside the transmission.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jcog7293
Lighting & Electrical
3
07-16-2012 09:30 PM
'96-Dirty4x4
The Lounge
7
01-09-2011 06:41 PM
tidoux01
Engine & Transmission
6
03-05-2007 07:07 PM
strongboy2005
General Tech Help
7
02-17-2006 10:40 AM


Thread Tools
Search this Thread
Quick Reply: 1999 ZR2 blazer 4.3l 2door lose power


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.