Sounds like spun bearing please help!! - Blazer Forum - Chevy Blazer Forums


Engine & Transmission Post your Engine and Transmission related problems here.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-12-2018, 11:12 PM
New Member
Thread Starter
 
Join Date: Jun 2018
Posts: 3
1998blazernewbie is on a distinguished road
Default Sounds like spun bearing please help!!

I have a 1998 Blazer I just bought off my brother. It has 104k miles in good shape never gave my brother any problems. Oil pressure has been good, runs great other than a misfire. I cleaned MAF, ran some seafom made it alittle better. Decided to changed cap and rotor and both looked worn. After replacing started right felt much better I was reving it to around 2500 rpm and then back to idle. After a few mins of running all the sudden I heard a small noise and then a sound like a really bad rod knock and lots of shaking in engine. Shut it off, started back up ran fine for a few seconds then really bad clunking sound in engine and shaking. All the wires are correct. Oil pressure still good. Any thoughts? I am praying itís not a spun bearing.
Reply With Quote
  #2  
Old 06-13-2018, 09:07 AM
Moderator
 
Join Date: Oct 2014
Location: North Central Indiana
Posts: 1,826
Lesmyer is on a distinguished road
Default

Quote:
Originally Posted by 1998blazernewbie View Post
I have a 1998 Blazer I just bought off my brother. It has 104k miles in good shape never gave my brother any problems. Oil pressure has been good, runs great other than a misfire. I cleaned MAF, ran some seafom made it alittle better. Decided to changed cap and rotor and both looked worn. After replacing started right felt much better I was reving it to around 2500 rpm and then back to idle. After a few mins of running all the sudden I heard a small noise and then a sound like a really bad rod knock and lots of shaking in engine. Shut it off, started back up ran fine for a few seconds then really bad clunking sound in engine and shaking. All the wires are correct. Oil pressure still good. Any thoughts? I am praying it’s not a spun bearing.
Sounds like the engine has big internal damage, either from dropping something into it or maybe a piece of valve. Compression test?
Reply With Quote
  #3  
Old 06-13-2018, 11:00 AM
New Member
Thread Starter
 
Join Date: Jun 2018
Posts: 3
1998blazernewbie is on a distinguished road
Default

canít compression test running to rough afraid of spun bearing it may further damage engine might be doing a rebuild now. I have never had an engine go from running great to out of no where having a catastrophic failure. No oil pressure drop nothing. Would a broken flexplate bolt cause this kind of shaking?
Reply With Quote
  #4  
Old 06-13-2018, 01:02 PM
Moderator
 
Join Date: Oct 2014
Location: North Central Indiana
Posts: 1,826
Lesmyer is on a distinguished road
Default

Quote:
Originally Posted by 1998blazernewbie View Post
canít compression test running to rough afraid of spun bearing it may further damage engine might be doing a rebuild now. I have never had an engine go from running great to out of no where having a catastrophic failure. No oil pressure drop nothing. Would a broken flexplate bolt cause this kind of shaking?
You don't do a compression test with the engine running. No, a broken flex plate would not do this. Spun bearings don't suddenly make an engine shake and misfire. Do the compression test. If you have one at zero, pressurize the cylinder using an air compressor and a hose adapter into the spark plug hole - then see where the air comes out. Intake, exhaust, or crankcase. Sounds like you dropped a piece of valve or some small part onto the top of the piston, and the piston now has a hole in it. Prepare yourself for this being a possibility, and the engine being toast. Sorry, but it seems the damage is already done.
Reply With Quote
  #5  
Old 06-16-2018, 04:21 PM
New Member
Thread Starter
 
Join Date: Jun 2018
Posts: 3
1998blazernewbie is on a distinguished road
Default

Itís not th engine I had some time today started it up it didnít make that sound then after a couple minutes started making it. Itís coming from the transmission. Itís making some kind of sound from the bell housing area that get worse if I rev it in park but not coming from engine. Itís loud enough at first that made me think it but engine is sounding fine. The sound from the trans is loud then stops and loud again.
Reply With Quote
  #6  
Old 06-17-2018, 07:28 AM
newguy's Avatar
BF Veteran
 
Join Date: Feb 2012
Location: Easthampton, ma.
Posts: 4,154
newguy will become famous soon enoughnewguy will become famous soon enough
Default

You asked for help take it
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
spun bearing ??? 88BLAZER4X4 Engine & Transmission 2 04-22-2014 10:01 PM
Refurb Crank Kit for spun bearing jfrankj21 Engine & Transmission 1 09-13-2012 10:40 AM
Engine spun a rod bearing Pete Chavez Engine & Transmission 4 08-14-2012 06:33 PM
Engine Knock - I expect a spun bearing R2P Engine & Transmission 10 05-08-2011 11:53 PM
Engine Rattle Suspect Spun Bearing mr.vls Engine & Transmission 1 11-12-2009 07:18 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 02:37 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.