Won’t hold fuel pressure , won’t start, new spider , new pump - Page 2 - Blazer Forum - Chevy Blazer Forums

Go Back  Blazer Forum - Chevy Blazer Forums > Mechanical & Maintenance > Engine & Transmission
Reload this Page >

Won’t hold fuel pressure , won’t start, new spider , new pump

Engine & Transmission Post your Engine and Transmission related problems here.
Sponsored by:
Sponsored by:

Won’t hold fuel pressure , won’t start, new spider , new pump

  #11  
Old 01-05-2019, 01:51 AM
odat's Avatar
Senior Member
Join Date: Sep 2013
Location: wyoming
Posts: 701
odat is on a distinguished road
Default

Just because parts are new and look high quality doesn't mean they are,
I have been working on a jeep, - clutch master cyl. - 4th new one installed.
New not refurb.They work for about 18 miles {distance from my shop to owners home} then they start bypassing internally
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Matt Lang
1st Gen S-series (1983-1994) Tech
5
04-15-2017 08:43 PM
Baxter1
Engine & Transmission
20
08-22-2016 12:39 PM
ynky
Engine & Transmission
17
07-09-2013 06:17 PM
Jamesrp7
1st Gen S-series (1983-1994) Tech
9
02-09-2013 12:43 PM
skidud
2nd Gen S-series (1995-2005) Tech
0
09-08-2010 09:54 AM


Thread Tools
Search this Thread
Quick Reply: Won’t hold fuel pressure , won’t start, new spider , new pump


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.