Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

1990 k5 ecm fuse blows after fuel pump installed

  #1  
Old 04-26-2011, 12:19 PM
New Member
Thread Starter
Join Date: Apr 2011
Posts: 2
xs2003 is on a distinguished road
Post 1990 k5 ecm fuse blows after fuel pump installed

Fuse blows with ing. off any ideas
 
  #2  
Old 04-27-2011, 07:26 AM
Starting Member
Join Date: Jul 2010
Location: Minnesota
Posts: 181
Z71_Guy is on a distinguished road
Default

was this happening before you did the pump, are you sure the pump was the issue, could have been the fuse the whole time?
only thing i could think of that would have to do with both is a ground some where.
 
  #3  
Old 04-28-2011, 03:46 PM
New Member
Thread Starter
Join Date: Apr 2011
Posts: 2
xs2003 is on a distinguished road
Default

No the fuse wasnt blowing before. However I pulled the battery & charged it because it went down for some reason. So I took off the breather and found the electronic control spark module and replaced it for $77.00 figured it cant hurt so for now it will start & run real good but I have not road tested it yet. Oh yeah the check engine or service engine soon light is but its been on before?
 

Last edited by xs2003; 04-28-2011 at 03:57 PM.
  #4  
Old 06-01-2011, 10:46 AM
New Member
Join Date: Sep 2010
Location: UTAH
Posts: 2
ROUGA is on a distinguished road
Default

When I replace the fuel pump I had to replace the relay Fuse on the firewall on the passenger side. this fuse may still work but may cause the fuel pump to grown out. Second on the frame of the driver side make sure the grown is connected all the way. The reason I say that it may come lose due to off road. You may want to reconnect the grown to somewhere in the engine compartment.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
michaelg793
2nd Gen S-series (1995-2005) Tech
4
08-27-2012 09:09 PM
roddy
2nd Gen S-series (1995-2005) Tech
1
06-28-2012 04:52 PM
ncpi
Engine & Transmission
3
10-12-2011 09:17 PM
DREWZBOY
1st Gen S-series (1983-1994) Tech
7
04-08-2010 11:50 PM
SevereDevil
2nd Gen S-series (1995-2005) Tech
1
06-12-2009 09:04 PM


Thread Tools
Search this Thread
Quick Reply: 1990 k5 ecm fuse blows after fuel pump installed


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.