Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

1990 K5 wont turn over

  #1  
Old 05-09-2010, 04:55 PM
Starting Member
Thread Starter
Join Date: May 2010
Location: Massachusetts
Posts: 194
THePaRaSiTE5771 is on a distinguished road
Default 1990 K5 wont turn over

Even more problems with the 1990 K5 now after taking it for a short ride about 4 1/2 hours ago, the truck will keep cranking but it wont turn over. I have no idea what could've happened. I literally let it sit for 4 hours and I come back to a truck that won't start up. I looked under the truck near the gas tank and noticed there are hoses that are cut. One is on the rear differential and the other looks like it's going to the gas tank and the third one goes below the body mounts and is clipped together along with a bunch of other hoses. I'm pretty much screwed so now, so I really need some help.
http://img689.imageshack.us/img689/6...0509174933.jpg
http://img22.imageshack.us/img22/200...0509174928.jpg
http://img98.imageshack.us/img98/400...0509191621.jpg
 

Last edited by THePaRaSiTE5771; 05-09-2010 at 07:11 PM. Reason: Pictures Added and information added
  #2  
Old 05-09-2010, 07:52 PM
1SLOW64's Avatar
Beginning Member
Join Date: Apr 2010
Location: in a mud hole
Posts: 22
1SLOW64 is on a distinguished road
Default

Have you checked for spark? Remove a plug wire from the spark plug and hold it to the block and have somebody crank the engine. See if there is spark.
What about fuel to the tbi? ahve you looked into the tbi while cranking to see if fuel is being delivered?
 
  #3  
Old 05-09-2010, 09:08 PM
Starting Member
Thread Starter
Join Date: May 2010
Location: Massachusetts
Posts: 194
THePaRaSiTE5771 is on a distinguished road
Default

Originally Posted by 1SLOW64 View Post
Have you checked for spark? Remove a plug wire from the spark plug and hold it to the block and have somebody crank the engine. See if there is spark.
What about fuel to the tbi? ahve you looked into the tbi while cranking to see if fuel is being delivered?
I was thinking the spark plugs were the cause of this. This is going to sound extremely stupid to you but I'm still learning, where would I look to see if there is fuel being delivered to the TBI?
 
  #4  
Old 05-10-2010, 04:09 PM
1SLOW64's Avatar
Beginning Member
Join Date: Apr 2010
Location: in a mud hole
Posts: 22
1SLOW64 is on a distinguished road
Default

Remove the air cleaner. That is where the TBI is located.
No worries. If you don't ask you won't know. Nothing wrong with learning.
 
  #5  
Old 05-10-2010, 06:43 PM
Starting Member
Thread Starter
Join Date: May 2010
Location: Massachusetts
Posts: 194
THePaRaSiTE5771 is on a distinguished road
Default

I took off the air filter and I was told By one of my friends to pour in a little gasoline And see if it starts. I have two questions: where do I pour the fuel and how much to pour?
 
  #6  
Old 05-10-2010, 08:59 PM
Starting Member
Thread Starter
Join Date: May 2010
Location: Massachusetts
Posts: 194
THePaRaSiTE5771 is on a distinguished road
Default

The blazer is back up and running, I poured some gas into the tbi and its running good now.
 
  #7  
Old 05-11-2010, 12:59 AM
Beginning Member
Join Date: May 2010
Posts: 23
Thid92 is on a distinguished road
Default

when you take the cover off for the air filter you see 2 injectors, have your friend crank the truck and you should see them mist down into the throttle body. hopefully what you did fixed the problem but in the future you know how to check if you are getting fuel.
 
  #8  
Old 05-11-2010, 04:00 PM
Starting Member
Thread Starter
Join Date: May 2010
Location: Massachusetts
Posts: 194
THePaRaSiTE5771 is on a distinguished road
Default

Yeah I fixed the problem, I started her up at 3:30 and it was running fine, took it for a ride.
 
  #9  
Old 05-11-2010, 06:56 PM
Ck1500's Avatar
Starting Member
Join Date: May 2010
Posts: 108
Ck1500 is on a distinguished road
Default

hmmm im confused, you poured gas into the TBI and its running now? why wouldnt it start without putting the gas into the TBI? thats a mystery there... unless fuel pump lost its prime or something. any other details we might be missing from this?

Ck1500
 
  #10  
Old 05-12-2010, 05:59 PM
Starting Member
Thread Starter
Join Date: May 2010
Location: Massachusetts
Posts: 194
THePaRaSiTE5771 is on a distinguished road
Default

Nope, all I did was just pour a bit of gas into the TBI and it runs fine now. I made a video about 3 hours ago:
http://www.youtube.com/watch?v=PcuhUxf9is4

No details that I left out either.
 

Thread Tools
Search this Thread
Quick Reply: 1990 K5 wont turn over


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.