Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

4WD fuse blowing!

  #1  
Old 03-16-2011, 07:01 PM
Beginning Member
Thread Starter
Join Date: Feb 2011
Posts: 13
HiRidinChevy93 is on a distinguished road
Default 4WD fuse blowing!

i bought this 93 fullsize blazer about a month ago, first thing when i got home i tried out the 4wd. i put it in 4wd hi and pulled forward and the light come on for a sec and flickerd out. i checked my fuse and it was blowed. i installed another fuse while in 2wd and it didnt blow, when i shifted to 4wd hi and pulled forward it blew again. i was just wondering a starting point yall might recommend. I do have a alldata sub to the vehicle if anyone needs it btw!
 
  #2  
Old 03-17-2011, 03:00 PM
Starting Member
Join Date: Jul 2010
Location: Minnesota
Posts: 181
Z71_Guy is on a distinguished road
Default

here is what i found for ya
 
Attached Thumbnails 4WD fuse blowing!-4x4.gif  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
AustinBlazer
2nd Gen S-series (1995-2005) Tech
6
06-04-2013 10:35 AM
champ186dc
2nd Gen S-series (1995-2005) Tech
11
01-09-2010 10:34 AM
crags
2nd Gen S-series (1995-2005) Tech
4
08-09-2009 08:04 PM
gERgMan
2nd Gen S-series (1995-2005) Tech
2
05-16-2008 10:12 AM
mrblonde108
General Tech Help
4
11-28-2006 10:56 AM


Thread Tools
Search this Thread
Quick Reply: 4WD fuse blowing!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.