Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

91 will start but no idle

  #1  
Old 06-27-2010, 02:29 PM
JDO
JDO is offline
New Member
Thread Starter
Join Date: Jun 2010
Location: MO
Posts: 8
JDO is on a distinguished road
Default 91 will start but no idle

Ok, my 91 Full size will start but will not idle, even when you give it some gas to try and keep it running it will rev up but if you try level it out it will die. I have changed plugs ,wires, cap, rotor, Air idle sensor, and TPS??? Any ideas out there???

Thanks for your time!!!!!
 
  #2  
Old 07-01-2010, 09:30 PM
JDO
JDO is offline
New Member
Thread Starter
Join Date: Jun 2010
Location: MO
Posts: 8
JDO is on a distinguished road
Default Need serious help

91 K5 350

Symptoms:

starts and runs for 3 sec.
good fuel flow for 2 sec.
good spark

Fuel relay replaced
In line fuel filter replaced
Air idle sensor replaced
TPS replaced
Rebuilt Fuel Pressure regulator, and TB


STUMPED!!!!
 
  #3  
Old 07-04-2010, 11:17 AM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,803
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

Any vacuum leaks? EGR clean and operational?

BTW, I merged your two threads. Please try to keep to one topic on a given problem. You can always bump the post if you have not received a reply after waiting 24 hours or more.
 
  #4  
Old 07-04-2010, 04:50 PM
Super Member
Join Date: Apr 2008
Posts: 1,125
mr.vls will become famous soon enough
Default

Is the Idle Air Sensor the same thing as the Idle Air Control (IAC) that is mounted on TBI? If not I would check that. I would check the voltage of your Throttle Position Sensor at idle (It may be out of spec. a scan tool can read the voltage). How are your injectors? EGR if leaking can cause idlw problems as at idle the EGR should be closed.
 
  #5  
Old 07-05-2010, 09:36 AM
JDO
JDO is offline
New Member
Thread Starter
Join Date: Jun 2010
Location: MO
Posts: 8
JDO is on a distinguished road
Default

Thank you all for your response's, I need some more please...EGR is good, TPS has the voltage, The Idle Air Control Module in the TBI is what I replaced.

There are some people telling me that it is the fuel pump, I guess I will buy a fuel pressure guage and let you all know if that is it....

Thanks again for all the ideas!!!!!

I do apologize for the two post swartlkk but it seemed the other post was not getting any responses????

JDO
 
  #6  
Old 07-20-2010, 04:13 PM
JDO
JDO is offline
New Member
Thread Starter
Join Date: Jun 2010
Location: MO
Posts: 8
JDO is on a distinguished road
Default update

I have dropped the fuel tank and it seemed as if the hose on the fuel pump was real gummy (nasty feeling) so I just ordered and new sending unit and pump...Will let you know if that was the problem....I hope...I hope.....I hope
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
djmehkae
Engine & Transmission
3
11-07-2017 08:08 PM
Kevin Gore
1st Gen S-series (1983-1994) Tech
3
12-13-2013 09:35 PM
tpolzin
2nd Gen S-series (1995-2005) Tech
7
08-30-2012 09:34 PM
prosnowsk8er
2nd Gen S-series (1995-2005) Tech
5
07-02-2012 01:49 PM


Thread Tools
Search this Thread
Quick Reply: 91 will start but no idle


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.