Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

Brand New to the K5 scene, asking for help :)

  #1  
Old 06-28-2011, 09:24 AM
Starting Member
Thread Starter
Join Date: Jun 2011
Posts: 2
zbest is on a distinguished road
Default Brand New to the K5 scene, asking for help :)

I just traded a 4wheeler for a 86 Chevy k5. it has a 350 with a cam, headers, holly carb, wieand intake. it also has a turbo 350 transmission.

I have lots of questions as the trucks has small issues all over. For instance windows the driver window does not make any noise i suspect the window motor. my back window rolls about half way down then appears to get stuck, not go down any farther, its a pain to get it back up.

My main concern is the truck has a ton of vacuum lines not hooked up, Ive capped off and hooked up as best i can but i know its not correct. I am having a hard time trying to find a Vacuum diagram for it, any suggestions please?

also there are a few sensors not working, Oil pressure, the coolant temp gauge is not working, im not sure if my fuel tank gauge is or not, i put like 30 dollars in and it seems to have only gone to a quarter tank? lol...

i am very reluctant to drive it for a long distance not knowing how hot the motor is getting. I appreciate any help/advice.

Also What is the best service book i can get for this truck? any recommendations? where to get it? i thiought about a Haynes or a Chilton but I'm just not sure.
 
  #2  
Old 06-28-2011, 11:55 AM
swartlkk's Avatar
Administrator
Join Date: May 2005
Location: Waterloo, NY
Posts: 40,795
swartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond reputeswartlkk has a reputation beyond repute
Default

Sounds like somewhat of a basket case. Check out Autozone's website for their repair info section. They tend to have a lot of useful information for the older, less complex vehicles.

There should be an oil pressure sending unit on the back rail of the engine block situated between the distributor and the brake booster (which is located on the firewall). The coolant temp sensor for the gauge should be located in the driver side cylinder head. Check both of these first to make sure that they are properly connected.

If you are planning on keeping the truck around for a long time to come, I would suggest getting a factory service manual set. eBay has a few for the Blazer/Suburban right now - $45 for the Service Manual & $35 for the Unit Repair Manual, both of which are well worth the expense.
 
  #3  
Old 06-29-2011, 08:02 AM
Starting Member
Thread Starter
Join Date: Jun 2011
Posts: 2
zbest is on a distinguished road
Default

Originally Posted by swartlkk View Post
Sounds like somewhat of a basket case. Check out Autozone's website for their repair info section. They tend to have a lot of useful information for the older, less complex vehicles.

There should be an oil pressure sending unit on the back rail of the engine block situated between the distributor and the brake booster (which is located on the firewall). The coolant temp sensor for the gauge should be located in the driver side cylinder head. Check both of these first to make sure that they are properly connected.

If you are planning on keeping the truck around for a long time to come, I would suggest getting a factory service manual set. eBay has a few for the Blazer/Suburban right now - $45 for the Service Manual & $35 for the Unit Repair Manual, both of which are well worth the expense.

I think ive found both sensors, i hooked up a couple lose wires, the oil pressure seems to be working, when i rev a little i see it move a little. I havnt gotten the temp gauge to work yet, do you guys know what color wire goes into the coolant temp sender? also if you know what color wire goes into the oil pressure sender that would be helpful just to make sure i have them hooked up right lol

thank you again guys, i appreciate the help.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Ghostblazer
General Chat
2
04-17-2012 06:55 PM
2xTheblazer
2nd Gen S-series (1995-2005) Tech
6
01-31-2010 06:46 AM
davidsv8mustang
General Chat
2
02-16-2009 12:21 PM
z
New Member Area
3
01-19-2008 01:14 PM


Thread Tools
Search this Thread
Quick Reply: Brand New to the K5 scene, asking for help :)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.