Full Size K5 (1969-1991) GMT415 (1992-1994) Tech Discuss any and all full size K5 general tech topics here.

died when running

  #1  
Old 02-14-2011, 07:57 PM
New Member
Thread Starter
Join Date: Feb 2011
Posts: 2
89blazer26 is on a distinguished road
Default died when running

My 89 blazer with 5.7L was running at idle for a couple of minutes and then died. I checked and i have no spark. I replaced every thing from distributor to the plugs. Someone mentioned the ecm. Any ideas out there to help me.
 
  #2  
Old 02-14-2011, 08:16 PM
s14sh3r's Avatar
Junior Member
Join Date: Jul 2009
Location: SE Oklahoma
Posts: 374
s14sh3r is on a distinguished road
Default

Start with the simple stuff: Check the fuse for the ECM (I'm assuming it has one, some full size guys can chime in if not), check to see that you're getting power to the ECM.
 
  #3  
Old 02-14-2011, 08:28 PM
New Member
Thread Starter
Join Date: Feb 2011
Posts: 2
89blazer26 is on a distinguished road
Default

The blazer is at my buddies house. but i did check the fuses and the were good. but how would i test to see if the ecm is getting power. and were can i find the ecm? I know a little mechanic stuff but not much
.
 

Last edited by 89blazer26; 02-14-2011 at 10:08 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ksimpson
2nd Gen S-series (1995-2005) Tech
14
10-07-2013 05:25 AM
hayndaddy22
Engine & Transmission
5
11-22-2007 09:53 AM
dhspark
2nd Gen S-series (1995-2005) Tech
2
11-21-2007 10:34 PM
57chevy
General Tech Help
1
02-13-2006 04:40 PM
Charidy
2nd Gen S-series (1995-2005) Tech
4
08-22-2005 02:18 PM


Thread Tools
Search this Thread
Quick Reply: died when running


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.